码迷,mamicode.com
首页 > 其他好文 > 详细

快速幂 生成素数表

时间:2014-11-18 00:24:47      阅读:157      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   color   ar   os   sp   java   



A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30672    Accepted Submission(s): 11006


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b‘s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b‘s last digit number.
 

Sample Input
7 66 8 800
 

Sample Output
9 6
 
#include<iostream>
#include<cstdio>
#include<cmath>

#define MOD 10
#define LL long long
using namespace std;



int  pow_mod(LL a,LL b)
{
    int num=1;
    while(b)
    {
        if(b&1)   num=(num*a)%MOD;  
        a=(a*a)%MOD;
        b>>=1;
    }
    return num;
}

int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        printf("%d\n",pow_mod(a,b));
    }
    return 0;
}


生成素数表:

void Prime(int x)
{
    for(int i=2;i<=x;i++)
    {
        if(flag[i]) continue;
         prime[cnt++]=i;
        for(int j=2;i*j<=x;j++)
            flag[i*j]=1;
    }
}



快速幂 生成素数表

标签:des   style   blog   io   color   ar   os   sp   java   

原文地址:http://blog.csdn.net/u013514722/article/details/41224643

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!