码迷,mamicode.com
首页 > 其他好文 > 详细

状压DP [HDU 3001] Travelling

时间:2014-11-18 01:30:08      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   color   ar   os   sp   

Travelling

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4166    Accepted Submission(s): 1339

Problem Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn‘t want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.
 

 

Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.
 

 

Output
Output the minimum fee that he should pay,or -1 if he can‘t find such a route.
 

 

Sample Input
2 1 1 2 100 3 2 1 2 40 2 3 50 3 3 1 2 3 1 3 4 2 3 10
 

 

Sample Output
100 90 7
 

 

Source
 


状压dp、仔细想一下

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define INF 0x3f3f3f3f

int n,m;
int s[12];
int mpt[12][12];
int tr[12][60000];
int dp[12][60000];

void init()                               //预处理s和tr数组
{
    int i,j,t;
    s[0]=1;
    for(i=1;i<=10;i++)
    {
        s[i]=3*s[i-1];
    }
    for(j=0;j<s[10];j++) 
    {
        t=j;
        for(i=0;i<10;i++) 
        {
            tr[i][j]=t%3;
            t/=3;
        }
    }
}
void solve() 
{
    int i,j,k,MAX=s[n];
    for(i=0;i<n;i++)
    {
        dp[i][s[i]]=0;
    }
    
    for(j=0;j<MAX;j++)
    {
        for(i=0;i<n;i++)
        {
            if(tr[i][j]==0) continue;
            for(k=0;k<n;k++)
            {
                if(i==k) continue;
                if(tr[k][j]==0) continue;
                int prej=j-s[i];
                dp[i][j]=min(dp[i][j],dp[k][prej]+mpt[k][i]);
            }
        }
    }
    
    int ans=INF;
    for(i=0;i<n;i++)
    {
        for(j=0;j<s[n];j++)
        {
            for(k=0;k<n;k++)
            {
                if(tr[k][j]==0) break;    
            }
            if(k==n)
                ans=min(ans,dp[i][j]);
        }
    }

    if(ans==INF)
        puts("-1");
    else
        printf("%d\n",ans);
}
int main ()
{
    init();
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dp,INF,sizeof(dp));
        memset(mpt,INF,sizeof(mpt));
        while(m--)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            a--;
            b--;
            if(c<mpt[a][b]) 
            {
                mpt[a][b]=c;
                mpt[b][a]=c;
            }
        }
        solve();
    }
    return 0;
}

 

状压DP [HDU 3001] Travelling

标签:des   style   blog   http   io   color   ar   os   sp   

原文地址:http://www.cnblogs.com/hate13/p/4104729.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!