码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1079 Calendar Game sg函数

时间:2014-11-18 01:31:57      阅读:109      评论:0      收藏:0      [点我收藏+]

标签:des   blog   io   ar   os   sp   java   for   strong   

Calendar Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2766    Accepted Submission(s): 1594


Problem Description
Adam and Eve enter this year’s ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid. 

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game. 

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy. 

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.
 

 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001. 
 

 

Output
Print exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of "YES" or "NO". 
 

 

Sample Input
3 2001 11 3 2001 11 2 2001 10 3
 

 

Sample Output
YES NO NO

 

代码风格太凌乱了导致没发现bug

#include <cstdio>
#include <cstring>
using namespace std;
int dayofmonth[12]={31,28,31,30,31,30,31,31,30,31,30,31};
int sg[45000];
bool isgapyear(int year){
    if(year%4==0&&(year%100!=0||year%400==0))return true;
    return false;
}
int getdofm(int year,int month){
    int ans=dayofmonth[month];
    if(month==1&&isgapyear(year))ans++;
    return ans;
}
int getdate(int year,int month,int day){
    int date=0;
    for(int i=1900;i<year;i++)date+=(isgapyear(i)?366:365);
    for(int i=0;i<month;i++){
        date+=getdofm(year,i);
    }
    date+=day;
    return date;
}
void getcalendar(int date ,int& year,int &month,int &day){
    int accu=0;
    for(int i=0;i<102;i++){
        accu+=(isgapyear(i+1900)?366:365);
        if(date<accu){
            year=i;date-=accu-(isgapyear(i+1900)?366:365);break;
        }
        else if(date==accu){
            year=i;day=31;month=11;return ;
        }
    }
    accu=0;
    for(int i=0;i<12;i++){
        int dm=getdofm(year+1900,i);
        accu+=dm;
        if(accu>date){
            month=i;
            date-=accu-dm;
            break;
        }
        else if(accu==date){
            month=i;
            date=dm;
            break;
        }
    }
    day=date;
}
int seg(int date){
    if(sg[date]!=-1)return sg[date];
    int year,month,day;
    getcalendar(date,year,month,day);
    if(seg(date+1)==0)return sg[date]=1;
    int ty,tm,td;getcalendar(date+getdofm(year+1900,month),ty,tm,td);
    if((day==td&&date+getdofm(year+1900,month)<=37198)&&seg(date+getdofm(year+1900,month))==0)return sg[date]=1;
    return sg[date]=0;
}
int main(){
    memset(sg,-1,sizeof(sg));
    sg[37198]=0;
    for(int i=37197 ;i>0;i--){
        seg(i);
    }
    int y,m,d;
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d%d",&y,&m,&d);m--;
        int date=getdate(y,m,d);
        printf("%s\n",seg(date)==0?"NO":"YES");
   }
    return 0;
}

  

hdu 1079 Calendar Game sg函数

标签:des   blog   io   ar   os   sp   java   for   strong   

原文地址:http://www.cnblogs.com/xuesu/p/4104716.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!