码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1003 hangover

时间:2014-11-18 23:24:09      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   io   ar   os   sp   for   strong   

Hangover
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 103896   Accepted: 50542

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We‘re assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.


bubuko.com,布布扣

Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)
这是我做的第二道水题,还有点小怀念
#include <iostream>
double tc;
double sum[300];
using namespace std;
int main(){
    ios::sync_with_stdio(false);
    double s=0;
    for(int i=0;i<300;i++){
        s+=1.00/(i+2);
        sum[i]=s;
    }
    while(cin>>tc&&tc){
        int i=0;
        for(int i=0;i<300;i++){
            if(sum[i]>=tc){
                cout<<i+1<<" card(s)"<<endl;
                break;
            }
        }
        if(i==300)cout<<"ERROR"<<endl;
    }
    return 0;
}

  

poj 1003 hangover

标签:des   blog   http   io   ar   os   sp   for   strong   

原文地址:http://www.cnblogs.com/xuesu/p/4106228.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!