码迷,mamicode.com
首页 > 其他好文 > 详细

zzu--2014年11月16日月赛 A题

时间:2014-11-19 01:25:58      阅读:161      评论:0      收藏:0      [点我收藏+]

标签:c语言   iostream   acm   c++   algorithm   

1228: Simple Molecules

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 22  Solved: 8
[Submit][Status][Web Board]

Description

Mad scientist Mike is busy carrying out experiments in chemistry. Today he will attempt to join three atoms into one molecule.

A molecule consists of atoms, with some pairs of atoms connected by atomic bonds. Each atom has a valence number — the number of bonds the atom must form with other atoms. An atom can form one or multiple bonds with any other atom, but it cannot form a bond with itself. The number of bonds of an atom in the molecule must be equal to its valence number.

bubuko.com,布布扣

Mike knows valence numbers of the three atoms. Find a molecule that can be built from these atoms according to the stated rules, or determine that it is impossible.

Input

The single line of the input contains three space-separated integers a, b, c (1 <= a, b, c <= 1^6) ----- the valence numbers of the given atoms.

Output

If such a molecule can be built, print three space-separated integers — the number of bonds between the 1-st and the 2-nd, the 2-nd and the 3-rd, the 3-rd and the 1-st atoms, correspondingly. If there are multiple solutions, output any of them. If there is no solution, print "Impossible" (without the quotes).

Sample Input

1 1 23 4 54 1 1

Sample Output

0 1 11 3 2Impossible

HINT

The first sample corresponds to the first figure. There are no bonds between atoms 1 and 2 in this case.


The second sample corresponds to the second figure. There is one or more bonds between each pair of atoms.


The third sample corresponds to the third figure. There is no solution, because an atom cannot form bonds with itself.


The configuration in the fourth figure is impossible as each atom must have at least one atomic bond.

Source

CF


题意:就是看能不能成化学键


思路:先判断能不能成化学键(用一个fun函数调用),然后再存1、2, 2、3, 3、1之间的bonds,存bonds时可以先判断前两个原子的化学键数!


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define max3(a,b,c) max(max(a,b),c)
using namespace std;

int fun(int a[], int b[])
{
	b[0] = a[0], b[1] = a[1], b[2] = a[2];
	sort(b, b+3);
	if(b[0]+b[1] < b[2]) return 0;
	else if(b[0]+b[1] >= b[2] && (b[0]+b[1]+b[2])%2==0) return 1;
	return 0;
}

int main()
{
	int a[3], b[3];
	while(scanf("%d %d %d", &a[0], &a[1], &a[2])!=EOF)
	{
		int t = fun(a, b);
		int bond[3]={0};
		if(t == 0)
		{
			printf("Impossible\n");
			continue;
		}
		else if(t == 1)
		{
			while(a[0]+a[1]!=a[2])
			{
				a[0]--;a[1]--;bond[0]++;
			}
			bond[1] = a[1]; bond[2] = a[0];
		}
		printf("%d %d %d\n", bond[0], bond[1], bond[2]);
	} 
	return 0;
}




zzu--2014年11月16日月赛 A题

标签:c语言   iostream   acm   c++   algorithm   

原文地址:http://blog.csdn.net/u014355480/article/details/41255239

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!