码迷,mamicode.com
首页 > 其他好文 > 详细

uva 10131

时间:2014-11-19 07:22:11      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   io   ar   os   sp   for   strong   

A - Is Bigger Smarter?
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Appoint description: 

Description

bubuko.com,布布扣
 

Question 1: Is Bigger Smarter?

The Problem

Some people think that the bigger an elephant is, the smarter it is. To disprove this, you want to take the data on a collection of elephants and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the IQ‘s are decreasing.

The input will consist of data for a bunch of elephants, one elephant per line, terminated by the end-of-file. The data for a particular elephant will consist of a pair of integers: the first representing its size in kilograms and the second representing its IQ in hundredths of IQ points. Both integers are between 1 and 10000. The data will contain information for at most 1000 elephants. Two elephants may have the same weight, the same IQ, or even the same weight and IQ.

Say that the numbers on the i-th data line are W[i] and S[i]. Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing an elephant). If these n integers are a[1]a[2],..., a[n] then it must be the case that

   W[a[1]] < W[a[2]] < ... < W[a[n]]
and
   S[a[1]] > S[a[2]] > ... > S[a[n]]
In order for the answer to be correct, n should be as large as possible. All inequalities are strict: weights must be strictly increasing, and IQs must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

 

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output

4
4
5
9
7
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<queue>
#include<vector>
#include<set>
using namespace std;
struct ele
{
	int w,s,id;
}a[1005];
int dp[1005],path[1005],MAX=-1;
bool comp(ele a1,ele a2)
{
	return a1.w<a2.w;
}
void printpath(int i)
{
	if(MAX--)
	{
		printpath(path[i]);
		printf("%d\n",a[i].id);
	}
}

int main()
{
	int i,j,p,k;
	k=1;
	while(~scanf("%d%d",&a[k].w,&a[k].s))
	{
		a[k].id=k;
		k++;
	}
	k--;
	sort(a+1,a+k,comp);
	for(i=1;i<=k;i++)
	{
		dp[i]=1;
		path[i]=i;
	}
	for(i=1;i<=k;i++)
	{
		for(j=1;j<i;j++)
		{
			if(a[i].w>a[j].w&&a[i].s<a[j].s&&dp[i]<dp[j]+1)
			{
				dp[i]=dp[j]+1;
				path[i]=j; /*记录i之前那头大象*/
			}
		    if(dp[i]>MAX)
			{
				MAX=dp[i];
				p=i;
			}
		}
	}
	printf("%d\n",MAX);
      printpath(p);
	return 0;
}

  

uva 10131

标签:des   blog   http   io   ar   os   sp   for   strong   

原文地址:http://www.cnblogs.com/a972290869/p/4107248.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!