码迷,mamicode.com
首页 > 其他好文 > 详细

uva 10003

时间:2014-11-19 08:36:51      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

E - Cutting Sticks
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

bubuko.com,布布扣
 

 

  Cutting Sticks 
You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time.

It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price.

Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.

 

Input 

The input will consist of several input cases. The first line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n ( n < 50) of cuts to be made.

The next line consists of n positive numbers ci ( 0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order.

An input case with l = 0 will represent the end of the input.

 

Output 

You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.

 

Sample Input 

100
3
25 50 75
10
4
4 5 7 8
0

 

Sample Output 

The minimum cutting is 200.
The minimum cutting is 22.

 


Miguel Revilla
2000-08-21
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<queue>
#include<vector>
#include<set>
using namespace std;
#define INF 1<<30
int dp[1005][1005],l,n,stick[1005];
int dfs(int x,int y)
{
      if(dp[x][y]!=-1)
            return dp[x][y];
      if(x+1==y)
      {
            dp[x][y]=0;
            return dp[x][y];
      }
      dp[x][y]=INF;
      for(int i=x+1;i<y;i++)
      {
            int temp=dfs(x,i)+dfs(i,y)+stick[y]-stick[x];
            if(temp<dp[x][y])
                  dp[x][y]=temp;
      }
      return dp[x][y];
}
int main()
{
      while(scanf("%d",&l),l)
      {
            memset(stick,0,sizeof(stick));
            memset(dp,-1,sizeof(dp));
            scanf("%d",&n);
            for(int i=1;i<=n;i++)
                  scanf("%d",&stick[i]);
            stick[0]=0,stick[n+1]=l;
            printf("The minimum cutting is %d.\n",dfs(0,n+1));
      }
      return 0;
}

  dp[i][j],表示从i到j切割花费的最小代价。

uva 10003

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://www.cnblogs.com/a972290869/p/4107353.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!