码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5073 Galaxy

时间:2014-11-19 11:11:04      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

Description

Good news for us: to release the financial pressure, the government started selling galaxies and we can buy them from now on! The first one who bought a galaxy was Tianming Yun and he gave it to Xin Cheng as a present. 

bubuko.com,布布扣

To be fashionable, DRD also bought himself a galaxy. He named it Rho Galaxy. There are n stars in Rho Galaxy, and they have the same weight, namely one unit weight, and a negligible volume. They initially lie in a line rotating around their center of mass. 

Everything runs well except one thing. DRD thinks that the galaxy rotates too slow. As we know, to increase the angular speed with the same angular momentum, we have to decrease the moment of inertia. 

The moment of inertia I of a set of n stars can be calculated with the formula 

bubuko.com,布布扣

where w i is the weight of star i, d i is the distance form star i to the mass of center. 

As DRD’s friend, ATM, who bought M78 Galaxy, wants to help him. ATM creates some black holes and white holes so that he can transport stars in a negligible time. After transportation, the n stars will also rotate around their new center of mass. Due to financial pressure, ATM can only transport at most k stars. Since volumes of the stars are negligible, two or more stars can be transported to the same position. 

Now, you are supposed to calculate the minimum moment of inertia after transportation.
 

Input

The first line contains an integer T (T ≤ 10), denoting the number of the test cases. 

For each test case, the first line contains two integers, n(1 ≤ n ≤ 50000) and k(0 ≤ k ≤ n), as mentioned above. The next line contains n integers representing the positions of the stars. The absolute values of positions will be no more than 50000.
 

Output

For each test case, output one real number in one line representing the minimum moment of inertia. Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.
 

Sample Input

2 3 2 -1 0 1 4 2 -2 -1 1 2
 

Sample Output

0 0.5

 

题意:给你2个数n,m   n代表有n个点,m代表能进行m次移动点的操作,要你求出最小的I,表示为所有的点到中心点的距离平方和最小


思路:  可以把所有的点按照顺序排列下来,每次选取(n-k)的区间内的i,枚举所有的(n-k)区间,找出最小的


AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;

#define N 50000+5

double  a[N],b[N];

int main()
{
    int n,k;
    int i,j;
    int t;
    double mid;
    double s1,s2;
    scanf("%d",&t);
    while(t--)
    {
        double sum=0;
        scanf("%d %d",&n,&k);
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        if(n!=k)
        {
            sort(a+1,a+n+1);
            for(i=1;i<=n;i++)
                b[i]=a[i]*a[i];
            s1=s2=0;
            for(i=1;i<=n-k;i++)
            {
                s1+=a[i];
                s2+=b[i];
            }
            sum=s2-s1*s1/(n-k);
            for(i=2,j=n-k+1;j<=n;i++,j++)
            {
                s1-=a[i-1];
                s1+=a[j];
                s2-=b[i-1];
                s2+=b[j];
                double t=s2-s1*s1/(n-k);
                if(t<sum)
                    sum=t;
            }
        }
        printf("%.12lf\n",sum);
    }
    return 0;
}


HDU 5073 Galaxy

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://blog.csdn.net/u012313382/article/details/41260987

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!