码迷,mamicode.com
首页 > 其他好文 > 详细

zzu--2014年11月16日月赛 E题

时间:2014-11-19 11:22:14      阅读:231      评论:0      收藏:0      [点我收藏+]

标签:水题   c语言   iostream   c++   algorithm   

Problem E: Fixed Points

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 29  Solved: 11
[Submit][Status][Web Board]

Description

A permutation of length n is an integer sequence such that each integer from 0 to (n - 1) appears exactly once in it. For example, sequence [0, 2, 1] is a permutation of length 3 while both [0, 2, 2] and [1, 2, 3] are not.

A fixed point of a function is a point that is mapped to itself by the function. A permutation can be regarded as a bijective function. We‘ll get a definition of a fixed point in a permutation. An integer i is a fixed point of permutation a[0], a[1], ..., a[n-1] if and only if a[i]=i . For example, permutation [0, 2, 1] has 1 fixed point and permutation [0, 1, 2] has 3 fixed points.

You are given permutation a. You are allowed to swap two elements of the permutation at most once. Your task is to maximize the number of fixed points in the resulting permutation. Note that you are allowed to make at most one swap operation.

Input

The first line contains a single integer n (1 <= n <= 10^5). The second line contains n integers a[0], a[1], ..., a[n - 1] ---- the given permutation.

Output

Print a single integer — the maximum possible number of fixed points in the permutation after at most one swap operation.

Sample Input

5
0 1 3 4 2

Sample Output

3

HINT


题意:找出最多交换两个数的位置的序列中a [ i ]  = i  的数的个数!


思路:因为最多就交换一次,ans最多也就多2, 然而只要满足了 i = a[ a[ i ] ] 就可以多2,否则多1或不变;


具体看代码(水水):


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int fun(int a[], int b[], int n)
{
	int flag=0;
	for(int i=0; i < n; i++)
	{
		if(b[i] == 0)
		{
			if(i == a[a[i]]) return 2;
			flag++;
		}
	}
	if(flag)return 1;
	else return 0;
}

int main()
{
	int n;
	int a[100010], is[100010];
	while(scanf("%d", &n) != EOF)
	{
		int ans=0;
		memset(is, 0, sizeof(is));
		memset(a, 0, sizeof(a));
		for(int i=0; i<n; i++)
		{
			scanf("%d", &a[i]);
			if(a[i] == i)
			{
				is[i] =1;
				ans++;
			}
		}
		printf("%d\n", ans+fun(a, is, n));
	}
	return 0;
}



zzu--2014年11月16日月赛 E题

标签:水题   c语言   iostream   c++   algorithm   

原文地址:http://blog.csdn.net/u014355480/article/details/41255723

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!