码迷,mamicode.com
首页 > 其他好文 > 详细

zzu--2014年11月16日月赛 C题

时间:2014-11-19 11:23:56      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:水题   c语言   iostream   c++   algorithm   

1230: Magnets

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 24  Solved: 13
[Submit][Status][Web Board]

Description

Mad scientist Mike entertains himself by arranging rows of dominoes. He doesn‘t need dominoes, though: he uses rectangular magnets instead. Each magnet has two poles, positive (a "plus") and negative (a "minus"). If two magnets are put together at a close distance, then the like poles will repel each other and the opposite poles will attract each other.

Mike starts by laying one magnet horizontally on the table. During each following step Mike adds one more magnet horizontally to the right end of the row. Depending on how Mike puts the magnet on the table, it is either attracted to the previous one (forming a group of multiple magnets linked together) or repelled by it (then Mike lays this magnet at some distance to the right from the previous one). We assume that a sole magnet not linked to others forms a group of its own.

bubuko.com,布布扣

Mike arranged multiple magnets in a row. Determine the number of groups that the magnets formed.

Input

The first line of the input contains an integer n (1 <= n <= 100000) ---- the number of magnets. Then n lines follow. The i-th line (1 <= i <= n) contains either characters "01", if Mike put the i-thmagnet in the "plus-minus" position, or characters "10", if Mike put the magnet in the "minus-plus" position.

Output

On the single line of the output print the number of groups of magnets.

Sample Input

6
10
10
10
01
10
10
4
01
01
10
10

Sample Output

3
2

HINT

The first testcase corresponds to the figure. The testcase has three groups consisting of three, one and two magnets.


The second testcase has two groups, each consisting of two magnets.

Source

CF


题意:就是去求一堆磁铁能分成几段!


大水题AC代码:

#include <stdio.h>

int main()
{
    char a[3];
    int n;
    while(scanf("%d", &n) != EOF)
    {
                      scanf("%s", a);
                      n--;
                      char cur = a[1];
                      int ans=1;
                      while(n--)
                      {
                                scanf("%s", a);
                                if(a[0] == cur)
                                {
                                        ans++;
                                        cur = a[1];
                                }
                      }
                      printf("%d\n", ans);
    }
    return 0;
}




zzu--2014年11月16日月赛 C题

标签:水题   c语言   iostream   c++   algorithm   

原文地址:http://blog.csdn.net/u014355480/article/details/41255463

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!