码迷,mamicode.com
首页 > 其他好文 > 详细

uva 10271

时间:2014-11-19 12:01:32      阅读:210      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   ar   os   sp   for   strong   

Problem C
Chopsticks
Input: Standard Input
Output: Standard Output

In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He uses a set of three chopsticks -- one pair, plus an EXTRA long chopstick to get some big food by piercing it through the food. As you may guess, the length of the two shorter chopsticks should be as close as possible, but the length of the extra one is not important, as long as it‘s the longest. To make things clearer, for the set of chopsticks with lengths A,B,C(A<=B<=C), (A-B)2 is called the ‘badness‘ of the set.

It‘s December 2nd, Mr.L‘s birthday! He invited K people to join his birthday party, and would like to introduce his way of using chopsticks. So, he should prepare K+8 sets of chopsticks(for himself, his wife, his little son, little daughter, his mother, father, mother-in-law, father-in-law, and K other guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find a way of composing the K+8 sets, so that the total badness of all the sets is minimized.

Input

The first line in the input contains a single integer T, indicating the number of test cases(1<=T<=20). Each test case begins with two integers K, N(0<=K<=1000, 3K+24<=N<=5000), the number of guests and the number of chopsticks. There are N positive integers Lion the next line in non-decreasing order indicating the lengths of the chopsticks.(1<=Li<=32000).

Output

For each test case in the input, print a line containing the minimal total badness of all the sets.

Sample Input

1
1 40
1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98 103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164

Sample Output

23

Note

For the sample input, a possible collection of the 9 sets is: 
8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160
__________________________________________________________________________________________
Rujia Liu

 

 dp[i][j],从前i个取出j对,关键需要考虑第i个是否在第j对中,dp[i][j]=min(dp[i-1][j],dp[i-2][j-1]+(a[i]-a[i-1])^2)
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<queue>
#include<vector>
#include<set>
using namespace std;
#define INF 1<<30
int t,n,k,dp[5010][1010],a[5010];
int main()
{
      scanf("%d",&t);
      while(t--)
      {
            memset(a,0,sizeof(a));
            memset(dp,0,sizeof(dp));
            scanf("%d%d",&k,&n);
            k+=8;
            for(int i=n;i>=1;i--)
                  scanf("%d",&a[i]);
            for(int i=1;i<=n;i++)
            {
                  dp[i][0]=0;
                  for(int j=1;j<=k;j++)
                        dp[i][j]=INF;
            }
            for(int i=3;i<=n;i++)
                  for(int j=1;j<=k;j++)
                        if((i>=j*3)&&dp[i-2][j-1]!=INF)
                              dp[i][j]=min(dp[i-1][j],dp[i-2][j-1]+(a[i]-a[i-1])*(a[i]-a[i-1]));
            printf("%d\n",dp[n][k]);
      }
      return 0;
}

  

uva 10271

标签:des   style   blog   io   ar   os   sp   for   strong   

原文地址:http://www.cnblogs.com/a972290869/p/4107675.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!