码迷,mamicode.com
首页 > 其他好文 > 详细

uva 116

时间:2014-11-19 15:56:35      阅读:255      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

D - Unidirectional TSP
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

bubuko.com,布布扣
 

 

 Unidirectional TSP 

 

Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) -- finding whether all the cities in a salesperson‘s route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

 

The Problem

Given an bubuko.com,布布扣 matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps‘‘ so that it represents a horizontal cylinder. Legal steps are illustrated below.

bubuko.com,布布扣

 

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different bubuko.com,布布扣 matrices are shown below (the only difference is the numbers in the bottom row).

 

bubuko.com,布布扣

 

The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

 

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by bubuko.com,布布扣 integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path‘s weight will exceed integer values representable using 30 bits.

 

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

 

Sample Input

 

5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10

 

Sample Output

 

1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19

dp[x][y] 表示 从(x,y)走到右边的最小花费,
路径输出 冏,慢慢理解= =
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<queue>
#include<vector>
#include<set>
using namespace std;
#define LL long long
#define inf 1e16

LL dp[11][111],w[11][111], mins, res[105];
int r, c;

struct point{
	int x, y;
}nxt[11][111];

LL dfs (int x, int y)
{
	if (y >= c) return (dp[x][y]=w[x][y]);
	if (dp[x][y] < inf)
		return dp[x][y];
	int i;
	LL tp = inf;
	for (i = x-1; i <= x+1; i++)
	{
		int tr = i;
		if (tr == 0) tr = r;
		else if (tr > r) tr = 1;
		LL tmp = dfs (tr, y+1) + w[x][y];
		if (tmp < tp || (tmp == tp && tr < nxt[x][y].x)) {
			nxt[x][y].x = tr;
			nxt[x][y].y = y+1;
			tp = tmp;
		}
	}
	return (dp[x][y]=tp);
}

int main()
{
	int i, j;
	while (cin >> r >> c)
	{
		for (i = 1; i <= r; i++)
			for (j = 1; j <= c; j++)
				cin >> w[i][j], dp[i][j] = inf;
		mins = inf;
		int v;
		memset (nxt, -1, sizeof(nxt));
		for (i = 1; i <= r; i++)
		{
			LL tp = dfs (i, 1);
			if (tp < mins) {
				mins = tp;
				v = i;
			}
		}
		int tc = 1, k = 0;
		while (v > 0)
		{
			res[k++] = v;
			int tv = v;
			v = nxt[tv][tc].x;
			tc = nxt[tv][tc].y;
		}
		cout << res[0];
		for (i = 1; i < k; i++) cout << ‘ ‘ << res[i];
		cout << endl << mins << endl;
	}
    return 0;
}

  

uva 116

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://www.cnblogs.com/a972290869/p/4108292.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!