码迷,mamicode.com
首页 > 其他好文 > 详细

DP HDU 1712

时间:2014-11-19 22:26:14      阅读:250      评论:0      收藏:0      [点我收藏+]

标签:dp   背包   

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4310    Accepted Submission(s): 2302


Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output
3 4 6
 

Source
 
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <queue>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <stack>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
#define MAXN 111
int dp[MAXN];
int cost[MAXN][MAXN];

int main(){
    int n,m;
    int i,j,k;

    while(~scanf("%d%d",&n,&m)){
        if(n==0 && m==0){
            break;
        }
        memset(cost,0,sizeof(cost));
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++){
            for(j=1;j<=m;j++){
                scanf("%d",&cost[i][j]);
            }
        }
        for(i=1;i<=n;i++){
            for(j=m;j>=0;j--){
                for(k=1;k<=j;k++){
                    dp[j] = max(dp[j],dp[j-k]+cost[i][k]);//用各种天数来来完成i获得的最大的价值
                }
            }
        }
        cout<<dp[m]<<endl;
    }

    return 0;
}


DP HDU 1712

标签:dp   背包   

原文地址:http://blog.csdn.net/zcr_7/article/details/41285677

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!