码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4960

时间:2014-11-21 01:24:59      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   io   ar   os   sp   java   for   

Another OCD Patient

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1168    Accepted Submission(s): 416


Problem Description
Xiaoji is an OCD (obsessive-compulsive disorder) patient. This morning, his children played with plasticene. They broke the plasticene into N pieces, and put them in a line. Each piece has a volume Vi. Since Xiaoji is an OCD patient, he can‘t stand with the disorder of the volume of the N pieces of plasticene. Now he wants to merge some successive pieces so that the volume in line is symmetrical! For example, (10, 20, 20, 10), (4,1,4) and (2) are symmetrical but (3,1,2), (3, 1, 1) and (1, 2, 1, 2) are not.

However, because Xiaoji‘s OCD is more and more serious, now he has a strange opinion that merging i successive pieces into one will cost ai. And he wants to achieve his goal with minimum cost. Can you help him?

By the way, if one piece is merged by Xiaoji, he would not use it to merge again. Don‘t ask why. You should know Xiaoji has an OCD.
 

 

Input
The input contains multiple test cases.

The first line of each case is an integer N (0 < N <= 5000), indicating the number of pieces in a line. The second line contains N integers Vi, volume of each piece (0 < Vi <=10^9). The third line contains N integers ai (0 < ai <=10000), and a1 is always 0. 

The input is terminated by N = 0.
 

 

Output
Output one line containing the minimum cost of all operations Xiaoji needs.
 

 

Sample Input
5 6 2 8 7 1 0 5 2 10 20 0
 

 

Sample Output
10
Hint
In the sample, there is two ways to achieve Xiaoji‘s goal. [6 2 8 7 1] -> [8 8 7 1] -> [8 8 8] will cost 5 + 5 = 10. [6 2 8 7 1] -> [24] will cost 20.
 

 

Author
SYSU
 

 

Source
 
dp[l][r]表示区间(l,r)的最小值。
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<set>
using namespace std;
#define N 5005
int n;
ll v[N],sum[N];
int a[N],dp[N][N];

int DP(int l,int r)
{
    if(dp[l][r]!=-1) return dp[l][r];
    dp[l][r]=a[r-l+1];
    if(l>=r) return dp[l][r]=0;
    int now=l;
    ll re;
    for(int i=r;i>=l;i--){
        re=sum[r]-sum[i-1];
        while(sum[now]-sum[l-1]<re && now<i)
            now++;
        if(now==i) break;
        if(sum[now]-sum[l-1]==re){
            dp[l][r]=min(dp[l][r],DP(now+1,i-1)+a[now-l+1]+a[r-i+1]);
        }
    }
    return dp[l][r];
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0) break;
        memset(dp,-1,sizeof(dp));
        for(int i=1;i<=n;i++){
            scanf("%I64d",&v[i]);
            sum[i]=sum[i-1]+v[i];
        }
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        DP(1,n);
        printf("%d\n",dp[1][n]);
    }

    return 0;
}

  

hdu 4960

标签:des   blog   http   io   ar   os   sp   java   for   

原文地址:http://www.cnblogs.com/a972290869/p/4111819.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!