码迷,mamicode.com
首页 > 其他好文 > 详细

01背包 HDU 2639,第K优解

时间:2014-11-21 09:12:39      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:01背包   第k优解   dp   

只要每次都保存前k优解就可以了

注意当价值一样时,只算一种,所以要进行去重复 的操作

用到了unique,

1 2 2 4 0 0

unique之后1 2 4 0 0 2

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2433    Accepted Submission(s): 1277


Problem Description
The title of this problem is familiar,isn‘t it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven‘t seen it before,it doesn‘t matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 231).
 

Sample Input
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
12 2 0
 

Author
teddy
 

Source
 
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
int dp[1111][33];
int cost[111];
int val[111];
int mark[111];

bool cmp(int a,int b){
    return a>b;
}

int main(){
    int T,n,v,i,j,k,kk;
    int con;

    while(~scanf("%d",&T)){
        while(T--){
            memset(dp,0,sizeof(dp));
            memset(cost,0,sizeof(cost));
            memset(val,0,sizeof(val));
            scanf("%d%d%d",&n,&v,&k);
            for(i=1;i<=n;i++){
                scanf("%d",&val[i]);
            }
            for(i=1;i<=n;i++){
                scanf("%d",&cost[i]);
            }
            for(i=1;i<=n;i++){
                for(j=v;j>=cost[i];j--){
                    con = 1;
                    memset(mark,0,sizeof(mark));
                    for(kk=1;kk<=k;kk++){
                        mark[con] = dp[j][kk];
                        con++;
                        mark[con] = dp[j-cost[i]][kk]+val[i];
                        con++;
                    }
                    sort(mark+1,mark+con+1,cmp);
                    unique(mark,mark+con+1);
                    for(int t=1;;t++){
                        if(mark[t] == 0){
                            for(int q=t+1;q<=66;q++){
                                mark[q] = 0;
                            }
                            break;
                        }
                    }
                    for(kk=1;kk<=k;kk++){
                        dp[j][kk] = mark[kk];
                    }
                }
            }
            printf("%d\n",dp[v][k]);
        }
    }

    return 0;
}


01背包 HDU 2639,第K优解

标签:01背包   第k优解   dp   

原文地址:http://blog.csdn.net/zcr_7/article/details/41324937

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!