码迷,mamicode.com
首页 > 其他好文 > 详细

HOJ 1797 Red and Black (DFS)

时间:2014-11-21 16:19:59      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:dfs

链接:点击打开链接


There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input 

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output 

45
59
6
13


最近很受伤,连一个kiss都搞得头昏眼花,刷个水题都肾痛~~我要疗伤了~~~

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <stack>
#include <queue>
#define MAXN 30
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

char Map[MAXN][MAXN];
int vis[MAXN][MAXN], n, m, res;
int bx, by, xx, yy;
const int dx[] = {-1, 0, 1, 0};
const int dy[] = {0, 1, 0, -1};

void Init()
{
    RST(vis);
    for(int i=0; i<n; i++) {
        scanf("%s", Map[i]);
        for(int j=0; Map[i][j]; j++) {
            if(Map[i][j] == '#') vis[i][j] = 1;
            if(Map[i][j] == '@') bx=i, by=j;
        }
    }
    res = 0;
}

bool check(int x, int y)
{
    return x>=0 && x<n && y>=0 && y<m && !vis[x][y];
}

void solve(int x, int y)
{
    vis[x][y] = 1;
    for(int i=0; i<4; i++) {
        xx = x+dx[i], yy = y+dy[i];
        if(check(xx, yy)) solve(xx, yy);
    }
    res++;
}

int main()
{
    while(~scanf("%d %d", &m, &n) && n || m) {
        Init();
        solve(bx, by);
        printf("%d\n", res);
    }
    return 0;
}



HOJ 1797 Red and Black (DFS)

标签:dfs

原文地址:http://blog.csdn.net/keshacookie/article/details/41348981

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!