码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2614

时间:2014-11-21 18:32:50      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   io   ar   os   sp   for   strong   

C - Beat
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve 
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one. 
You should help zty to find a order of solving problems to solve more difficulty problem. 
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve. 
 

Input

The input contains multiple test cases. 
Each test case include, first one integer n ( 2< n < 15).express the number of problem. 
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j. 
 

Output

For each test case output the maximum number of problem zty can solved. 


 

Sample Input

3 0 0 0 1 0 1 1 0 0 3 0 2 2 1 0 1 1 1 0 5 0 1 2 3 1 0 0 2 3 1 0 0 0 3 1 0 0 0 0 2 0 0 0 0 0
 

Sample Output

3 2 4

Hint

 Hint: sample one, as we know zty always solve problem 0 by costing 0 minute. So after solving problem 0, he can choose problem 1 and problem 2, because T01 >=0 and T02>=0. But if zty chooses to solve problem 1, he can not solve problem 2, because T12 < T01. So zty can choose solve the problem 2 second, than solve the problem 1. 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
using namespace std;
int  a[20][20],n,ans,vis[20];
void dfs(int now,int num,int dif)//当前做now题,做题数,上次数量
{
      if(num>ans)
            ans=num;
      for(int i=1;i<n;i++)
      {
          if(vis[i]||a[now][i]<dif)
            continue;
          vis[i]=1;//选i题
          dfs(i,num+1,a[now][i]);
          vis[i]=0;//不选i题
      }
}
int main()
{
      while(scanf("%d",&n)!=EOF)
      {
            ans=0;
            for(int i=0;i<n;i++)
                  for(int j=0;j<n;j++)
                        scanf("%d",&a[i][j]);
            vis[0]=1;
            dfs(0,1,0);
            printf("%d\n",ans);
      }
      return 0;
}

  

hdu 2614

标签:des   blog   http   io   ar   os   sp   for   strong   

原文地址:http://www.cnblogs.com/a972290869/p/4113214.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!