码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1326_Box of Bricks【水题】

时间:2014-11-21 20:33:03      阅读:138      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   ar   os   sp   java   for   

Box of Bricks


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4540    Accepted Submission(s): 2031

Problem Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I‘ve built a wall!‘‘, he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.‘‘, she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help? 
bubuko.com,布布扣

Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height. 

The input is terminated by a set starting with n = 0. This set should not be processed. 
 
Output
For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.‘‘, where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height. 

Output a blank line after each set.
 
Sample Input
6
5 2 4 1 7 5
0
 
Sample Output
Set #1
The minimum number of moves is 5.
 
Source

Southwestern Europe 1997


题目大意:给你N堆砖块的高度,为了使N堆砖块的高度已知,需要把高的堆上的

砖块移到低的堆上,问最少需要移多少块砖。

思路:计算出总共的砖块数,在求出N堆砖的平均高度(即需要达到的最终高度),把

高的堆上的砖移到不足平均高度的堆上。应该计算出所有不足高度的堆上总共差多少

砖达到高度,即为结果。

#include<stdio.h>
#include<string.h>

int main()
{
    int N;
    int a[55];
    int kase = 1;
    while(scanf("%d",&N) && N)
    {
        int sum = 0;
        for(int i = 0; i < N; i++)
        {
            scanf("%d",&a[i]);
            sum += a[i];
        }
        int ans = 0;
        for(int i = 0; i < N; i++)
        {
            if(a[i] < sum/N)
                ans += sum/N - a[i];
        }
        printf("Set #%d\n",kase++);
        printf("The minimum number of moves is %d.\n\n",ans);
    }

    return 0;
}


HDU1326_Box of Bricks【水题】

标签:des   style   http   io   ar   os   sp   java   for   

原文地址:http://blog.csdn.net/lianai911/article/details/41356655

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!