码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1080-Human Gene Functions(DP)

时间:2014-11-21 21:59:18      阅读:215      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

Human Gene Functions
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17300   Accepted: 9617

Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them. 

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. 
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet. 

A database search will return a list of gene sequences from the database that are similar to the query gene. 
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed. 

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity 
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of 
the genes to make them equally long and score the resulting genes according to a scoring matrix. 

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal 
length. These two strings are aligned: 

AGTGAT-G 
-GT--TAG 

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix. 
bubuko.com,布布扣

denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. 

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions): 

AGTGATG 
-GTTA-G 

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the 
similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14
21 
LCS变形;
题意  :求两个字符串匹配能够获得的最大价值,可以加空格,其中字符与字符匹配所得到价值如上表。
LCS匹配,设串s和t 得分矩阵为score[][];
dp[i][j]=max(dp[i-1][j-1]+score[s[i-1]][t[j-1]],dp[i-1][j]+score[s[i-1]][‘-‘],dp[i][j-1]+score[‘-‘][t[j-1]])
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <cctype>
#include <vector>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
#define ll long long
#define maxn 360
#define pp pair<int,int>
#define INF 0x3f3f3f3f
#define max(x,y) ( ((x) > (y)) ? (x) : (y) )
#define min(x,y) ( ((x) > (y)) ? (y) : (x) )
using namespace std;
char s[120],t[120];
int lens,lent,dp[120][120];
int sb[5][5]={5,-1,-2,-1,-3,-1,5,-3,-2,-4,-2,-3,5,-2,-2,-1,-2,-2,5,-1,-3,-4,-2,-1,-INF};
int change(char x)
{
	if(x=='A')return 0;
	else if(x=='C')return 1;
	else if(x=='G')return 2;
	else return 3;
}
void solve()
{
	dp[0][0]=0;
	for(int i=1;i<=lens;i++)
		dp[i][0]=dp[i-1][0]+sb[change(s[i-1])][4];
	for(int i=1;i<=lent;i++)
		dp[0][i]=dp[0][i-1]+sb[4][change(t[i-1])];
	for(int i=1;i<=lens;i++)
		for(int j=1;j<=lent;j++)
		if(s[i-1]==t[j-1])
		dp[i][j]=dp[i-1][j-1]+5;
		else
		dp[i][j]=max(max(dp[i-1][j]+sb[change(s[i-1])][4],dp[i][j-1]+sb[4][change(t[j-1])]),dp[i-1][j-1]+sb[change(s[i-1])][change(t[j-1])]);
	printf("%d\n",dp[lens][lent]);

}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d %s %d %s",&lens,s,&lent,t);
		solve();
	}
	return 0;
}

POJ 1080-Human Gene Functions(DP)

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://blog.csdn.net/qq_16255321/article/details/41357127

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!