码迷,mamicode.com
首页 > 其他好文 > 详细

hdu5108Alexandra and Prime Numbers(素数的性质)

时间:2014-11-22 23:12:16      阅读:280      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

题目链接:

huangjing

思路:每一个数都可以表示成若干个素数的乘积,那么可以对N从2一直枚举到sqrt(N),然后对每个数都能除到不能取余为止,那么后面的合数就不会除了,所以最后得到的数就是最大的质因子,然后直接N/最大的质因子,还有就是N=1的时候没有存在的数  。

题目:

Alexandra and Prime Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 259    Accepted Submission(s): 94


Problem Description
Alexandra has a little brother. He is new to programming. One day he is solving the following problem: Given an positive integer N, judge whether N is prime.
The problem above is quite easy, so Alexandra gave him a new task: Given a positive integer N, find the minimal positive integer M, such that N/M is prime. If such M doesn‘t exist, output 0.
Help him!
 

Input
There are multiple test cases (no more than 1,000). Each case contains only one positive integer N.
N1,000,000,000.
Number of cases with N>1,000,000 is no more than 100.
 

Output
For each case, output the requested M, or output 0 if no solution exists.
 

Sample Input
3 4 5 6
 

Sample Output
1 2 1 2
 

Source
 

Recommend
#include<cstdio>
#include<vector>
#include<iostream>
#include<algorithm>
using namespace std;


vector<int>ans;
int n;

int main()
{
    while(~scanf("%d",&n))
    {
        int k=n;
        ans.clear();
        if(n==1) printf("0\n");
        else
        {
            for(int i=2;i*i<=n;i++)
            {
                while(n%i==0)
                {
                    ans.push_back(i);
                    n=n/i;
                }
            }
            if(n!=1)  ans.push_back(n);
            sort(ans.begin(),ans.end());
            printf("%d\n",k/ans.back());
        }
    }
    return 0;
}


代码:


hdu5108Alexandra and Prime Numbers(素数的性质)

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://blog.csdn.net/u014303647/article/details/41390709

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!