码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 4666 Hyperspace 最大曼哈顿距离

时间:2014-11-23 00:44:14      阅读:238      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   


二进制转化,求最大曼哈顿距离....


Hyperspace

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1123    Accepted Submission(s): 530


Problem Description
The great Mr.Smith has invented a hyperspace particle generator. The device is very powerful. The device can generate a hyperspace. In the hyperspace, particle may appear and disappear randomly. At the same time a great amount of energy was generated.
However, the device is in test phase, often in a unstable state. Mr.Smith worried that it may cause an explosion while testing it. The energy of the device is related to the maximum manhattan distance among particle.
Particles may appear and disappear any time. Mr.Smith wants to know the maxmium manhattan distance among particles when particle appears or disappears.
 

Input
The input contains several test cases, terminated by EOF.
In each case: In the first line, there are two integer q(number of particle appear and disappear event, ≤60000) and k(dimensions of the hyperspace that the hyperspace the device generated, ≤5). Then follows q lines. In each line, the first integer ‘od’ represents the event: od = 0 means this is an appear
event. Then follows k integer(with absolute value less then 4 × 107). od = 1 means this is an disappear event. Follows a integer p represents the disappeared particle appeared in the pth event.
 

Output
Each test case should contains q lines. Each line contains a integer represents the maximum manhattan distance among paticles.
 

Sample Input
10 2 0 208 403 0 371 -180 1 2 0 1069 -192 0 418 -525 1 5 1 1 0 2754 635 0 -2491 961 0 2954 -2516
 

Sample Output
0 746 0 1456 1456 1456 0 2512 5571 8922
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>

using namespace std;

const int maxn=66000;

int n,k,id;
int mat[maxn][5];
int pos[maxn];
multiset<int> SET[50];

void init()
{
    id=0;
    int nn=1<<k;
    for(int i=0;i<nn;i++)
        SET[i].clear();
}

int getSum(int id,int x)
{
    int sum=0;
    for(int i=0;i<k;i++)
    {
        if(x&(1<<i)) sum+=mat[id][i];
        else sum-=mat[id][i];
    }
    return sum;
}

void add(int x)
{
    int nn=1<<k;
    for(int i=0;i<nn;i++)
    {
        int xx=getSum(x,i);
        SET[i].insert(xx);
    }
}

void rm(int x)
{
    int nn=1<<k;
    for(int i=0;i<nn;i++)
    {
        int xx=getSum(x,i);
        SET[i].erase(SET[i].find(xx));
    }
}

int check()
{
    int nn=1<<k;
    int ans=0;
    for(int i=0;i<nn;i++)
    {
        multiset<int>::iterator S,E;
        S=SET[i].begin();
        E=SET[i].end();
        E--;
        ans=max(ans,*E-*S);
    }
    return ans;
}

int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        init();
        int kind;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&kind);
            if(kind==0)
            {
                for(int j=0;j<k;j++)
                {
                    scanf("%d",&mat[id][j]);
                }
                add(id);
                pos[i+1]=id;
                id++;
            }
            else
            {
                int rmid;
                scanf("%d",&rmid);
                rm(pos[rmid]);
            }
            printf("%d\n",check());
        }
    }
    return 0;
}


HDOJ 4666 Hyperspace 最大曼哈顿距离

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://blog.csdn.net/ck_boss/article/details/41393789

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!