标签:acm algorithm hdu c++ 素数
Alexandra and Prime Numbers
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 319 Accepted Submission(s): 120
Problem Description
Alexandra has a little brother. He is new to programming. One day he is solving the following problem: Given an positive integer N, judge whether N is prime.
The problem above is quite easy, so Alexandra gave him a new task: Given a positive integer N, find the minimal positive integer M, such that N/M is prime. If such M doesn‘t exist, output 0.
Help him!
Input
There are multiple test cases (no more than 1,000). Each case contains only one positive integer N.
N≤1,000,000,000.
Number of cases with N>1,000,000 is
no more than 100.
Output
For each case, output the requested M, or output 0 if no solution exists.
Sample Input
Sample Output
Source
居然直接暴力过!!太坑爹了,我居然没做:-(,不然就涨rating了.....
AC代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int main()
{
int n;
while(scanf("%d", &n)!=EOF)
{
if(n == 1)
{
printf("0\n");
continue;
}
int maxz = 1, t = n;
int i;
for(i=2; i<=(int)sqrt(n*1.0); i++)
{
while(t%i==0)
{
t/=i;
maxz = i;
}
}
maxz = max(maxz, t);
printf("%d\n", n/maxz);
}
return 0;
}
HDU-5108-Alexandra and Prime Numbers (BestCoder Round #19)
标签:acm algorithm hdu c++ 素数
原文地址:http://blog.csdn.net/u014355480/article/details/41392141