码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4708 Rotation Lock Puzzle(数学啊)

时间:2014-11-23 20:19:41      阅读:221      评论:0      收藏:0      [点我收藏+]

标签:数学   hdu   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4708


Problem Description
Alice was felling into a cave. She found a strange door with a number square matrix. These numbers can be rotated around the center clockwise or counterclockwise. A fairy came and told her how to solve this puzzle lock: “When the sum of main diagonal and anti-diagonal is maximum, the door is open.”.
Here, main diagonal is the diagonal runs from the top left corner to the bottom right corner, and anti-diagonal runs from the top right to the bottom left corner. The size of square matrix is always odd.

bubuko.com,布布扣


This sample is a square matrix with 5*5. The numbers with vertical shadow can be rotated around center ‘3’, the numbers with horizontal shadow is another queue. Alice found that if she rotated vertical shadow number with one step, the sum of two diagonals is maximum value of 72 (the center number is counted only once).
 

Input
Multi cases is included in the input file. The first line of each case is the size of matrix n, n is a odd number and 3<=n<=9.There are n lines followed, each line contain n integers. It is end of input when n is 0 .
 

Output
For each test case, output the maximum sum of two diagonals and minimum steps to reach this target in one line.
 

Sample Input
5 9 3 2 5 9 7 4 7 5 4 6 9 3 9 3 5 2 8 7 2 9 9 4 1 9 0
 

Sample Output
72 1
 

Source


代码如下:

#include<cstdio>
int minn(int a,int b)
{
    return a<b?a:b;
}
int main()
{
    int n;
    int a[17][17];
	while(~scanf("%d",&n) && n)
	{
		int sum = 0, pos = 0;
		int i, j;
		int mid = (n+1)/2;
		for(i = 1; i <= n; i++)
		{
			for(j = 1; j <= n; j++)
			{
				scanf("%d",&a[i][j]);
				if(i==mid && j==mid)
				{
					sum = a[i][j];
				}
			}
		}
		int tsum = 0, tpos = 0;
		for(i = 1; i <= (n-1)/2; i++) //层数
		{
			for(j = i; j <= n-i; j++)
			{
				int tt=(a[j][i]+a[n-j+1][n-i+1])+(a[n-i+1][j]+a[i][n-j+1]); //主副对角线相加
				if(j==i || tsum<tt)
				{
					tsum = tt;
					tpos = minn(j-i,n-(i+j)+1);//逆时针,顺时针
				}
			}
			pos+=tpos;
			sum+=tsum;
		}
		printf("%d %d\n",sum,pos);
	}
    return 0;
}


HDU 4708 Rotation Lock Puzzle(数学啊)

标签:数学   hdu   

原文地址:http://blog.csdn.net/u012860063/article/details/41414231

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!