码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3176_Cow Bowling【数塔DP】

时间:2014-11-24 17:21:46      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   ar   os   sp   for   on   div   

Cow Bowling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14253 Accepted: 9461


Description


The cows don‘t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7

       3   8

      8   1   0
    2   7   4   4
  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow‘s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.


Input


Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
Output

Line 1: The largest sum achievable using the traversal rules


Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5


Sample Output

30


Hint

Explanation of the sample: 
          7
         *
        3   8
       *
      8   1   0
       *
    2   7   4   4
       *
  4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.


Source

USACO 2005 December Bronze


题目大意:给你一个三角形的数塔,问从上走到最下边,得到最大的和是多少

思路:从下往上推,当前值大的和上边的值相加

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[400][400],map[400][400];
int main()
{
    int N;
    while(~scanf("%d",&N))
    {
        memset(map,0,sizeof(map));
        for(int i = 1; i <= N; i++)
        {
            for(int j = 1; j <= i; j++)
            {
                scanf("%d",&map[i][j]);
            }
        }
        memset(dp,0,sizeof(dp));
        for(int i = N; i >= 1; i--)
        {

            for(int j = 1; j <= i; j++)
            {
                if(i == N)
                    dp[i][j] = map[i][j];
                else
                    dp[i][j] = max(dp[i+1][j],dp[i+1][j+1]) + map[i][j];
            }
        }
        printf("%d\n",dp[1][1]);
    }
    return 0;
}


POJ3176_Cow Bowling【数塔DP】

标签:des   style   io   ar   os   sp   for   on   div   

原文地址:http://blog.csdn.net/lianai911/article/details/41445955

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!