码迷,mamicode.com
首页 > 其他好文 > 详细

nyoj-248-buying feed

时间:2014-11-24 20:50:04      阅读:228      评论:0      收藏:0      [点我收藏+]

标签:style   blog   http   io   ar   color   os   sp   for   

http://acm.nyist.net/JudgeOnline/problem.php?pid=248

 

BUYING FEED

时间限制:3000 ms  |  内存限制:65535 KB
难度:4
描述

Farmer John needs to travel to town to pick up K (1 <= K <= 100)pounds of feed. Driving D miles with K pounds of feed in his truck costs D*K cents.

The county feed lot has N (1 <= N<= 100) stores (conveniently numbered 1..N) that sell feed. Each store is located on a segment of the X axis whose length is E (1 <= E <= 350). Store i is at location X_i (0 < X_i < E) on the number line and can sell John as much as F_i (1 <= F_i <= 100) pounds of feed at a cost of C_i (1 <= C_i <= 1,000,000) cents per pound.
Amazingly, a given point on  the X axis might have more than one store.

Farmer John  starts  at location 0 on this number line and can drive only in the positive direction, ultimately arriving at location E, with at least K pounds of feed. He can stop at any of the feed stores along the way and buy any amount of feed up to the the store‘s limit.  What is the minimum amount Farmer John has to pay to buy and transport the K pounds of feed? Farmer John
knows there is a solution.
 Consider a sample where Farmer John  needs two pounds of feed from three stores (locations: 1, 3, and 4) on a number line whose range is 0..5:     
0   1   2  3   4   5
    
---------------------------------
         
1       1   1                Available pounds of feed
         
1       2   2               Cents per pound

It is best for John to buy one pound of feed from both the second and third stores. He must pay two cents to buy each pound of feed for a total cost of 4. When John travels from 3 to 4 he is moving 1 unit of length and he has 1 pound of feed so he must pay1*1 = 1 cents.

When John travels from 4 to 5 heis moving one unit and he has 2 pounds of feed so he must pay 1*2 = 2 cents. The total cost is 4+1+2 = 7 cents.

输入
The first line of input contains a number c giving the number of cases that follow
There are multi test cases ending with EOF.
Each case starts with a line containing three space-separated integers: K, E, and N
Then N lines follow :every line contains three space-separated integers: Xi Fi Ci
输出
For each case,Output A single integer that is the minimum cost for FJ to buy and transport the feed
样例输入
2 5 3                  
3 1 2 
4 1 2 
1 1 1 
样例输出
7

 

解题思路:有C个样例,每个样例第一行有三个整数k, e, n,分别表示农夫要买的种子数量, 这条道路的长度, 何在该条路上的商店数量,接下来n行,每行三个数字xi, fi, ci,分别表示在xi位置的店家有fi的种子且单位重量的种子的运费为ci,让你求到达目的地需要花费最少多少运费, 可以先求出每种种子运到终点的运费之后贪心

 

 1 #include <stdio.h>
 2 #include <stdlib.h>
 3 #include <math.h>
 4 #include <string.h>
 5 
 6 struct P{
 7     int xi;
 8     int fi;
 9     int ci;
10     int cost;
11 }p[110];
12 
13 int cmp(const void *a, const void *b){
14     struct P *c = (struct P *)a;
15     struct P *d = (struct P *)b;
16     return c->cost - d->cost;
17 }
18 int main(){
19     int c, k, e, n;
20     int i;
21     int ans;
22     while(scanf("%d", &c) != EOF){
23         while(c--){
24             scanf("%d %d %d", &k, &e, &n);
25             for(i = 0; i < n; i++){
26                 scanf("%d %d %d", &p[i].xi, &p[i].fi, &p[i].ci);
27                 //计算当前点1单位的种子运到重点需要花费多少?
28                 p[i].cost = e - p[i].xi + p[i].ci;
29             }
30             qsort(p, n, sizeof(p[0]), cmp);
31 //            for(i = 0; i < n; i++){
32 //                printf("%d %d %d %d\n", p[i].xi, p[i].fi, p[i].ci, p[i].cost);
33 //            }
34             ans = i = 0;
35             while(k >= p[i].fi){
36                 ans += p[i].fi * p[i].cost;
37                 k -= p[i].fi;
38                 i++;
39             }
40             if(k > 0){
41                 ans += k * p[i].cost;
42             }
43             printf("%d\n", ans);
44         }
45     }
46     return 0;

47 } 

nyoj-248-buying feed

标签:style   blog   http   io   ar   color   os   sp   for   

原文地址:http://www.cnblogs.com/angle-qqs/p/4119532.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!