标签:poj c++
Number Sequence
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 34391 |
|
Accepted: 9879 |
Description
A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910
Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)
Output
There should be one output line per test case containing the digit located in the position i.
Sample Input
2
8
3
Sample Output
2
2
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
typedef long long ll;
const ll maxn=40000;
ll a[maxn],b[maxn];
void init(){
a[1]=b[1]=1;
for(ll i=2;i<maxn;i++){
a[i]=a[i-1]+(int)log10((double)i)+1;
b[i]=b[i-1]+a[i];
}
return ;
}
ll f(ll m){
ll i=1;
while(b[i]<m) i++;
int p=m-b[i-1];
int len=0;
for(i=1;len<p;i++)
len+=(int)log10((double)i)+1;
return (i-1)/(int)pow((double)10,len-p)%10;
}
int main(){
init();
int T;
cin>>T;
while(T--){
ll n;
cin>>n;
cout<<f(n)<<endl;
}
}
poj 1019 Number Sequence 二分
标签:poj c++
原文地址:http://blog.csdn.net/hyccfy/article/details/41453565