码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1551 Cable master(二分)

时间:2014-11-24 22:40:47      阅读:306      评论:0      收藏:0      [点我收藏+]

标签:hdu 1551   cable master   二分   

Cable master

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2003    Accepted Submission(s): 751


Problem Description
Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.

To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter, and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.

You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
 

Input
The input consists of several testcases. The first line of each testcase contains two integer numbers N and K, separated by a space. N (1 ≤ N ≤ 10000) is the number of cables in the stock, and K (1 ≤ K ≤ 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 centimeter and at most 100 kilometers in length. All lengths in the input are written with a centimeter precision, with exactly two digits after a decimal point.

The input is ended by line containing two 0‘s.
 

Output
For each testcase write to the output the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output must contain the single number "0.00" (without quotes).
 

Sample Input
4 11 8.02 7.43 4.57 5.39 0 0
 

Sample Output
2.00
 

Source
 

题意:
有n条绳子,分成k段相等的,问能使得最长为多长

题解:二分查找绳子的长度

CODE:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>

#define N 100010
#define Mod 10000007
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
#define lc idx<<1
#define rc idx<<1|1
const double EPS = 1e-11;
const double PI = acos(-1.0);
const double E=2.718281828;
typedef long long ll;

const int INF=100000;

using namespace std;

int n,k;
double l[101000];

bool C(double x)
{

	int num=0;///当每段绳子的长度为x时,所有绳子可分的段数和
	for(int i=0;i<n;i++)
	{
		num+=(int)(l[i]/x);
	}
	return num>=k;///返回是否有k断
}

int main()
{
	while(cin>>n>>k)
	{
		if(n==0&&k==0)
			break;
			for(int i=0;i<n;i++)
				scanf("%lf",&l[i]);
		double lb=0,ub=INF;
		for(int i=0;i<100;i++)
		{
			double mid=(lb+ub)/2;
			if(C(mid))
				lb=mid;
			else ub=mid;
		}
		printf("%.2f\n",lb);
	}
  return 0;
}




hdu 1551 Cable master(二分)

标签:hdu 1551   cable master   二分   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/41451257

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!