码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4763 stone(博弈)

时间:2014-11-25 00:16:19      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

F - Stone
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students. 
 

Input

There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero. 
 

Output

For each case, print the winner‘s name in a single line. 
 

Sample Input

1 1 30 3 10 2 0 0
 

Sample Output

Jiang Tang Jiang
 
 
简单博弈 运用逆推
要赢得胜利就必须占据 n-1 点 而且要避开 n-1-k ~n-2 之间的点
以此类推 可以推出 只要 (n-1)%(k+1) 不为0  第一个人就能胜利
 
bubuko.com,布布扣
#include<cstdio>
int main()
{
    int n,k;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        if(n==0&&k==0) break;
        int que=(n-1)%(k+1);
        if(que>0&&que<=k) printf("Tang\n");
            else printf("Jiang\n");
    }
    return 0;
}
View Code

 

hdu 4763 stone(博弈)

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://www.cnblogs.com/sola1994/p/4119884.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!