码迷,mamicode.com
首页 > 其他好文 > 详细

整数解(杭电2092)

时间:2014-11-25 00:19:29      阅读:207      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

整数解

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22049    Accepted Submission(s): 7693


Problem Description
有二个整数,它们加起来等于某个整数,乘起来又等于另一个整数,它们到底是真还是假,也就是这种整数到底存不存在,实在有点吃不准,你能快速回答吗?看来只能通过编程。
例如:
x + y = 9,x * y = 15 ? 找不到这样的整数x和y
1+4=5,1*4=4,所以,加起来等于5,乘起来等于4的二个整数为1和4
7+(-8)=-1,7*(-8)=-56,所以,加起来等于-1,乘起来等于-56的二个整数为7和-8
 

Input
输入数据为成对出现的整数n,m(-10000<n,m<10000),它们分别表示整数的和与积,如果两者都为0,则输入结束。
 

Output
只需要对于每个n和m,输出“Yes”或者“No”,明确有还是没有这种整数就行了。
 

Sample Input
9 15 5 4 1 -56 0 0
 

Sample Output
No Yes Yes
 

Author
qianneng
 

Source
#include<stdio.h>
int main()
{
	int i,k;
	double n,m;
	while(scanf("%lf%lf",&n,&m)&&(n+m))
	{
		k=0;
		for(i=-9999;i<=9999;i++)
		{
			if(i*(n-i)==m)
			{
				k=1;
				break;
			}
		}
		if(k==1)
		printf("Yes\n");
		else
		printf("No\n");
	}
	return 0;
} 


整数解(杭电2092)

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://blog.csdn.net/hdd871532887/article/details/41460805

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!