码迷,mamicode.com
首页 > 其他好文 > 详细

The 3n + 1 problem(杭电1032)(暴力求解)

时间:2014-11-25 00:21:13      阅读:233      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   ar   color   os   sp   java   

The 3n + 1 problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23163    Accepted Submission(s): 8653


Problem Description
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm: 


    1.      input n

    2.      print n

    3.      if n = 1 then STOP

    4.           if n is odd then n <- 3n + 1

    5.           else n <- n / 2

    6.      GOTO 2


Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 
 

Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0. 

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j. 

You can assume that no opperation overflows a 32-bit integer.
 

Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line). 
 

Sample Input
1 10 100 200 201 210 900 1000
 

Sample Output
1 10 20 100 200 125 201 210 89 900 1000 174
 

Source
/*对于这道题真心无语了,如果m>n,则需要调换m,n,
但是输出结果还是原本输入的m,n,原本用打表法做超时。
测试数据太坑了! 
*/
#include<stdio.h>
int main()
{
	int i,t,max,m,n,k,a,b;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		a=m,b=n;
		if(m>n)
		{
			t=m;
			m=n;
			n=t;
		}
		for(i=m,max=0;i<=n;i++)
		{
			t=i;
			k=0;
			while(t!=1)
			{
				k++;
				if(t%2==1)
				t=t*3+1;
				else
				t/=2;
			}
			if(max<k)
			max=k;
		}
		printf("%d %d %d\n",a,b,max+1);
	}
	return 0;
} 

The 3n + 1 problem(杭电1032)(暴力求解)

标签:des   style   http   io   ar   color   os   sp   java   

原文地址:http://blog.csdn.net/hdd871532887/article/details/41458605

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!