码迷,mamicode.com
首页 > 其他好文 > 详细

Integer Inquiry(大数相加)

时间:2014-11-25 14:39:38      阅读:275      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   ar   color   os   sp   for   on   

Description

One of the first users of BIT‘s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,‘‘ remarked Chip. ``I only wish Timothy were here to see these results.‘‘ (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670
#include<iostream>
#include<string.h>
using namespace std;
int main()
{
	char a[1000];	
	int i,j,x;
    while(cin>>a)
	{
		int sum[101]={0};
		while(1)
		{
			int b[100]={0};
			if(strcmp(a,"0")==0)
				break;
			int t=strlen(a);
			x=99;
			for(i=t-1;i>=0;i--)
				b[x--]=a[i]-'0';
			for(i=0;i<100;i++)
				sum[i]+=b[i];
			x=0;
			for(i=99;i>=0;i--)
			{
				sum[i]+=x;
				x=0;
			    if(sum[i]>9)
				{
					x=sum[i]/10;
				    sum[i]=sum[i]%10;
				}
			}
			cin>>a;
		}
		for(i=0;i<100;i++)
		{
			if(sum[i]!=0)
				break;
		}
		for(j=i;j<100;j++)
			cout<<sum[j];
		cout<<endl;
	}
	return 0;
}

Integer Inquiry(大数相加)

标签:des   style   io   ar   color   os   sp   for   on   

原文地址:http://blog.csdn.net/phytn/article/details/41479129

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!