码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1979 Red and Black(dfs)

时间:2014-11-25 16:30:39      阅读:107      评论:0      收藏:0      [点我收藏+]

标签:poj 1979   red and black   dfs   

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 23191   Accepted: 12510

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source



题意:给定一矩形棋盘,上面仅有黑棋和红棋,要求只能在黑棋上移动,且规定移动方向上下左右,给定一起点,求从起点可到达的所以黑棋的个数(包括起点)。

CODE:
#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstdlib>

using namespace std;

char a[22][22];
int n, m, ans;

void dfs ( int s1, int s2 )
{
    if ( s1 <= m - 1 && s2 <= n - 1 && a[s1][s2] == '.' && s1 >= 0 && s2 >= 0 )
    {
        ans++;
        a[s1][s2] = '#';
    }
    else
        return;
    dfs ( s1, s2 + 1 );
    dfs ( s1, s2 - 1 );
    dfs ( s1 + 1, s2 );
    dfs ( s1 - 1, s2 );
}

int main()
{
    while ( cin >> n >> m && ( n + m ) )
    {
        int s1, s2;
        for ( int i = 0; i < m; i++ )
            for ( int j = 0; j < n; j++ )
            {
                cin >> a[i][j];
                if ( a[i][j] == '@' )
                {
                    s1 = i, s2 = j;
                    a[i][j] = '.';
                }
            }
        ans = 0;
        dfs ( s1, s2 );
        printf ( "%d\n", ans );
    }
    return 0;
}


poj 1979 Red and Black(dfs)

标签:poj 1979   red and black   dfs   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/41482597

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!