码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1339_A Simple Task【水题】

时间:2014-11-25 23:30:28      阅读:321      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   ar   os   sp   java   for   on   

A Simple Task


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3987    Accepted Submission(s): 2181

Problem Description
Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.

Example

For n = 24, o = 3 and p = 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the odd integer o and the nonnegative integer p such that n = o2^p,

writes the result.

Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
 
Output
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.
 
Sample Input
1
24
 
Sample Output
3 3
 
Source

Central Europe 2001, Practice


题目大意:给你一个数N,输出满足N = o*2^p(o为奇数,p为非负数)的o和p值

思路:除以2算出2的幂p,剩下的就是奇数o


#include<stdio.h>
#include<string.h>

int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int a = 0;
        while(!(n&1))
        {
            a++;
            n >>= 1;
        }
        printf("%d %d\n",n,a);
    }

    return 0;
}


HDU1339_A Simple Task【水题】

标签:des   style   io   ar   os   sp   java   for   on   

原文地址:http://blog.csdn.net/lianai911/article/details/41494975

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!