码迷,mamicode.com
首页 > 其他好文 > 详细

二分快速幂 [FOJ ] 1752

时间:2014-11-26 15:58:42      阅读:217      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

Problem 1752 A^B mod C

Accept: 750    Submit: 3205
Time Limit: 1000 mSec    Memory Limit : 32768 KB

bubuko.com,布布扣 Problem Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<2^63).

bubuko.com,布布扣 Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

bubuko.com,布布扣 Output

For each testcase, output an integer, denotes the result of A^B mod C.

bubuko.com,布布扣 Sample Input

3 2 4 2 10 1000

bubuko.com,布布扣 Sample Output

1 24

bubuko.com,布布扣 Source

二分快速幂模板题
#include <iostream>
#include <cstdio>
using namespace std;
#define ll __int64

ll quickadd(ll a,ll b,ll c)    //运用快速幂的思想快速加,这样就不会溢出
{
    ll ret=0;
    while(b)
    {
        if(b&1)
        {
            ret+=a; 
            if(ret>=c) ret-=c; //这样比直接取模(ret%=c)更快
        }
        a<<=1;
        if(a>=c) a-=c;
        b>>=1;
    }
    return ret;
}
ll quickpow(ll a,ll b,ll c)
{
    ll ret=1;
    while(b)
    {
        if(b&1) ret=quickadd(a,ret,c);
        a=quickadd(a,a,c);
        b>>=1;
    }
    return ret;
}
int main()
{
    ll a,b,c;
    while(scanf("%I64d%I64d%I64d",&a,&b,&c)!=EOF)
    {
        printf("%I64d\n",quickpow(a%c,b,c));
    }
    return 0;
}

 

二分快速幂 [FOJ ] 1752

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://www.cnblogs.com/hate13/p/4123380.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!