码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1078_FatMouse and Cheese【记忆化搜索】

时间:2014-11-26 16:36:57      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   ar   os   sp   java   for   

FatMouse and Cheese


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5124    Accepted Submission(s): 2076

Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he‘s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 
Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1‘s. 
 
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 
Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output
37

Source

Zhejiang University Training Contest 2001


题目大意:有个N*N格子的正方形,每个单位格子里放有0~100块奶酪。

有一只老鼠站在左上角,他每次只能水平或竖直移动k步,且它只吃它当

前所站的格子的奶酪和比这个格子上的奶酪多的格子上的奶酪。问:这只

老鼠最多能吃到多少奶酪。

思路:从左上角(0,0)开始,找到一条最长的路径,使得这条路径上满足从

(Xi,Yi)->(Xi+1,Yi+1)满足map[Xi+1][Yi+1]>map[Xi][Yi],且在水平方向

上或竖直方向上所走步数2不超过k。这里用dire数组来存上下左右4个方

向。j*dire[i][0]和j*dire[i][1]表示横向和纵向所走步数。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int N,k,map[110][110],dp[110][110],dire[4][2]={{0,1},{0,-1},{1,0},{-1,0}};

int dfs(int x,int y,int k,int N)
{
    if(dp[x][y])
        return dp[x][y];
    int MaxSum = 0;
    for(int i = 0; i < 4; i++)
    {
        for(int j = 1; j <= k; j++)
        {
            int tx = x + j*dire[i][0];
            int ty = y + j*dire[i][1];
            if(tx >= 0 && tx < N && ty >= 0 && ty < N &&map[tx][ty] > map[x][y])
            {
                MaxSum = max(MaxSum,dfs(tx,ty,k,N));
            }
        }
    }
    dp[x][y] = MaxSum + map[x][y];
    return dp[x][y];
}
int main()
{
    while(~scanf("%d%d",&N,&k) && (N!=-1 && k!=-1))
    {
        memset(map,0,sizeof(map));
        memset(dp,0,sizeof(dp));
        for(int i = 0; i < N; i++)
            for(int j = 0; j < N; j++)
                scanf("%d",&map[i][j]);

        int ans = dfs(0,0,k,N);
        printf("%d\n",ans);
    }
    return 0;
}



HDU1078_FatMouse and Cheese【记忆化搜索】

标签:des   style   blog   io   ar   os   sp   java   for   

原文地址:http://blog.csdn.net/lianai911/article/details/41516041

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!