码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-4464-Browsing History (2012 ACM/ICPC成都现场赛!)

时间:2014-11-26 22:44:52      阅读:227      评论:0      收藏:0      [点我收藏+]

标签:acm区域赛   hdu   algorithm   成都   icpc   

Browsing History

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3065    Accepted Submission(s): 1692


Problem Description
One day when you are going to clear all your browsing history, you come up with an idea: You want to figure out what your most valued site is. Every site is given a value which equals to the sum of ASCII values of all characters in the URL. For example aa.cc has value of 438 because 438 = 97 + 97 + 46 + 99 + 99. You just need to print the largest value amongst all values of sites.
Things are simplified because you found that all entries in your browsing history are of the following format: [domain], where [domain] consists of lower-case Latin letters and “.” only. See the sample input for more details.
 

Input
There are several test cases.
For each test case, the first line contains an integer n (1 ≤ n ≤ 100), the number of entries in your browsing history.
Then follows n lines, each consisting of one URL whose length will not exceed 100.
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a number indicating the desired answer.
 

Sample Input
1 aa.cc 2 www.google.com www.wikipedia.org
 

Sample Output
Case 1: 438 Case 2: 1728
 

Source
 


水题不解释....

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
	int n, k = 1;
	char a[105];
	while(~scanf("%d", &n))
	{
		int ans=0;
		n--;
		scanf("%s", a);
		for(int i=0; i<strlen(a); i++)
		{
			ans+=a[i];
		}
		while(n--)
		{
			scanf("%s", a);
			int tmp = 0;
			for(int i = 0; i<strlen(a); i++)
			{
				tmp += a[i];
			}
			if(tmp>ans) ans = tmp;
		}
		printf("Case %d: %d\n", k++, ans);
	}
	return 0;
}



HDU-4464-Browsing History (2012 ACM/ICPC成都现场赛!)

标签:acm区域赛   hdu   algorithm   成都   icpc   

原文地址:http://blog.csdn.net/u014355480/article/details/41521745

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!