码迷,mamicode.com
首页 > 其他好文 > 详细

Slim Span

时间:2014-11-26 22:45:41      阅读:364      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   ar   color   os   sp   for   

Description

Given an undirected weighted graph G , you should find one of spanning trees specified as follows.

The graph G is an ordered pair (V, E) , where V is a set of vertices {v1, v2,..., vn} and E is a set of undirected edges {e1, e2,..., em} . Each edge ebubuko.com,布布扣E has its weight w(e) .

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n - 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n - 1 edges of T .

bubuko.com,布布扣

For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5} . The weights of the edges are w(e1) = 3 , w(e2) = 5 , w(e3) = 6 , w(e4) = 6 , w(e5) = 7 as shown in Figure 5(b).

=6in bubuko.com,布布扣

There are several spanning trees for G . Four of them are depicted in Figure 6(a)a??(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb , Tc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.


nm
a1b1w1
bubuko.com,布布扣
ambmwm


Every input item in a dataset is a non-negative integer. Items in a line are separated by a space.


n is the number of the vertices and m the number of the edges. You can assume 2bubuko.com,布布扣nbubuko.com,布布扣100 and 0bubuko.com,布布扣mbubuko.com,布布扣n(n - 1)/2 . ak and bk(k = 1,..., m) are positive integers less than or equal to n , which represent the two vertices vak and vbk connected by the k -th edge ek . wk is a positive integer less than or equal to 10000, which indicates the weight of ek . You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, `-1‘ should be printed. An output should not contain extra characters.

Sample Input

4 5 
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6 
1 2 10 
1 3 100 
1 4 90 
2 3 20 
2 4 80 
3 4 40 
2 1 
1 2 1
3 0 
3 1 
1 2 1
3 3 
1 2 2
2 3 5 
1 3 6 
5 10 
1 2 110 
1 3 120 
1 4 130 
1 5 120 
2 3 110 
2 4 120 
2 5 130 
3 4 120 
3 5 110 
4 5 120 
5 10 
1 2 9384 
1 3 887 
1 4 2778 
1 5 6916 
2 3 7794 
2 4 8336 
2 5 5387 
3 4 493 
3 5 6650 
4 5 1422 
5 8 
1 2 1 
2 3 100 
3 4 100 
4 5 100 
1 5 50 
2 5 50 
3 5 50 
4 1 150 
0 0

Sample Output

1 
20 
0 
-1 
-1 
1 
0 
1686 
50

题意:给出n,m代表n个点、m条边;接下来m行是两个顶点和他们之间的权值;题目要求是找出最小生成树;即用n-1条线连接各个点;找出权值

最大的边和权值最小的边的差值。选取最小的差输出;

思路:将每条边按权值从小到大排序,然后用枚举的方法选出权值最小的差;

<span style="font-size:14px;"># include <cstdio>
# include <vector>
# include <algorithm>
# include <iostream>
using namespace std;

int pra[110],ans,n;
const int INF=10000000;

struct node
{
    int s,e,v;
    node (int s,int e,int v): s(s),e(e),v(v)  {};
    bool operator < (const node & n) const
    {
        return v < n.v;
    }
};

vector < node > q;
int find (int x)    { return pra[x] == x ? x : pra[x]=find(pra[x]); }     //并查集查找是不是同一个祖先,即看选取的边是不是会组成一个环

void solve()
{
    int i,m;
    m=q.size();
    sort(q.begin(), q.end());
    for(int L=0;L<m;L++)
    {
        int cnt=n;
        for(i=0;i<=n;i++)    pra[i]=i;    //将每个数的祖先重置;
        for(int R=L;R<m;R++)
        {
            int s = find(q[R].s),e = find(q[R].e);
            if(s!=e)
            {
                pra[s]=e;
                if(--cnt==1)   { ans = ans < q[R].v-q[L].v ? ans : q[R].v-q[L].v; break;}
            }
        }
    }
    if(ans==INF)    cout<<-1<<"\n";
    else    cout<<ans<<"\n";
    return ;
}

int main()
{
    //freopen("a.txt","r",stdin);
    int m,s,e,v;
    while(cin>>n>>m&&n)
    {
        q.clear();
        int i;
        for(i=0;i<m;i++)
        {
            cin>>s>>e>>v;
            q.push_back(node(s,e,v));
        }
        ans=INF;
        solve();
    }
    return 0;
}</span>



Slim Span

标签:des   style   http   io   ar   color   os   sp   for   

原文地址:http://blog.csdn.net/rechard_chen/article/details/41520699

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!