码迷,mamicode.com
首页 > 其他好文 > 详细

括号匹配问题

时间:2014-11-27 00:05:42      阅读:274      评论:0      收藏:0      [点我收藏+]

标签:blog   http   io   ar   os   sp   on   数据   div   

括号配对问题

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
 
描述
现在,有一行括号序列,请你检查这行括号是否配对。
 
输入
第一行输入一个数N(0<N<=100),表示有N组测试数据。后面的N行输入多组输入数据,每组输入数据都是一个字符串S(S的长度小于10000,且S不是空串),测试数据组数少于5组。数据保证S中只含有"[","]","(",")"四种字符
输出
每组输入数据的输出占一行,如果该字符串中所含的括号是配对的,则输出Yes,如果不配对则输出No
样例输入
3
[(])
(])
([[]()])
样例输出
No
No
Yes
来源
网络
上传者
naonao

 

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<vector>
#include<set>
#include<stack>
using namespace std;
int n;
char ch;
stack<char> s;
int main()
{
      scanf("%d",&n);
      getchar();
      while(n--)
      {
            while(scanf("%c",&ch)&&ch!=‘\n‘)
            {
                  if(s.empty())
                        s.push(ch);
                  else
                  {
                        if(ch==‘(‘||ch==‘[‘)
                              s.push(ch);
                        else
                        {
                              if(ch==‘)‘&&s.top()==‘(‘)
                                    s.pop();
                              else if(ch==‘]‘&&s.top()==‘[‘)
                                    s.pop();
                              else
                                    s.push(ch);
                        }
                  }
            }
            if(s.empty())
                  printf("Yes\n");
            else
                  printf("No\n");
            while(!s.empty())
                  s.pop();
      }
      return 0;
}

  

括号匹配问题

标签:blog   http   io   ar   os   sp   on   数据   div   

原文地址:http://www.cnblogs.com/a972290869/p/4125370.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!