标签:des style blog http io ar color os sp
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13680 Accepted Submission(s): 5239
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the leftmost digit of N^N.
Sample Input
Sample Output
2
2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
题目大意:给正整数n,问n^n的最左面的那位数是多少。
解析:高大上的数论,确实对数学的智商不怎么够用。下为借鉴网上大神的思路:
一个数是由每一位的基数乘以相对应的权值,例如 123456 , 基数"1"的权值为 10^5, 基数 "2" 的权值为 10^4......所以该题要求的就是最高位的基数。
对 x^x 取对数,得 x* ln( x )/ ln( 10 ), 现假设这个值为 X.abcdeefg 那么 10^X 就是 最高位对应的权值,10^ 0.abcdefg 就是最高位的基数。注意这里得到的并不是一个整数,为什么呢? 因为这里是强行将后面位的值也转化到最高位上来了,这有点像大数中,如果不满进制却强行进位,显然那样会进给高位一个小数而不是一个天经地义的整数。得到 10^ 0.abcdefg 后,再用 double
floor ( double ) 函数取下整就得到最高位的数值大小了
详解请参见博客:http://www.cnblogs.com/jackge/archive/2013/01/03/2842830.html
AC代码:
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int main(){
// freopen("in.txt", "r", stdin);
int t, n;
scanf("%d", &t);
while(t--){
scanf("%d", &n);
double foo = n * log10(double(n)); //需强转
double ans = foo - floor(foo);
printf("%d\n", (int)pow(10.0, ans));
}
return 0;
}
HDU 1060 Leftmost Digit (数论)
标签:des style blog http io ar color os sp
原文地址:http://blog.csdn.net/u013446688/article/details/41553607