码迷,mamicode.com
首页 > 其他好文 > 详细

[ACM] sdut 2877 angry_birds_again_and_again (简单数学积分)

时间:2014-11-27 22:11:30      阅读:392      评论:0      收藏:0      [点我收藏+]

标签:acm   数学积分   

angry_birds_again_and_again

Time Limit: 2000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

The problems called "Angry Birds" and "Angry Birds Again and Again" has been solved by many teams in the series of contest in 2011 Multi-University Training Contest.
 
This time we focus on the yellow bird called Chuck. Chuck can pick up speed and distance when tapped.
 
You can assume that before tapped, Chuck flies along the parabola. When tapped, it changes to fly along the tangent line. The Chuck starts at the coordinates (0,?0). Now you are given the coordinates of the pig (Px,?0), the x-coordinate of the tapping position (Tx) and the initial flying angle of Chuck (α).
bubuko.com,布布扣
∠AOx?=?α
Please calculate the area surrounded by Chuck’s path and the ground.(The area surrounded by the solid line O-Tapping position-Pig-O)

输入

The first line contains only one integer T (T is about 1000) indicates the number of test cases. For each case there are two integers, px tx, and a float number α.(0?<?Tx?≤?Px?≤?1000, 0?<?α?<? bubuko.com,布布扣) .

输出

One line for each case specifying the distance rounded to three digits.

示例输入

1
2 1 1.0

示例输出

0.692

提示

 

来源

2014年山东省第五届ACM大学生程序设计竞赛


解题思路:

设方程 y=ax^2+bx+c ,图中曲线经过原点,所以c=0.

对方程求导 y‘=2ax+b ,  y‘代表斜率,那么原点(0,0)这一点,代人y‘=b,即该点的斜率,根据题意b=tan( α)

如图:在题目中x=tx这一点时,容易混,记tx为t, 图中曲线x=t这一点,该点的斜率为  2at+b . 注意斜率是负的

三角形竖着的直角边除以横着的直角边(p-t)的值的相反数即为斜率 2at+b

竖着的直角边值为 at^2+bt (将t带入原方程),横着的直角边为p-t,则有式子

2at+b= - ( at^2+bt)/(p-t)

解出a,这样方程中a,b的值都有了。

那么题目所求的面积即为 曲线覆盖面积 从 0到t积分 积分函数为(ax^2+bx)  ,再加上三角形的面积 0.5*(p-t)*(at^2+bt)

代码:

#include <iostream>
#include <cmath>
#include <iomanip>
using namespace std;

double px,tx,jiao;
double a,b;

int main()
{
    int t;cin>>t;
    while(t--)
    {
        cin>>px>>tx>>jiao;
        b=tan(jiao);
        double m=px-tx;
        a=(-b*tx-b*m)/(2*tx*m+tx*tx);
        double ans;
        ans=(1/3.0)*a*tx*tx*tx+0.5*b*tx*tx+0.5*(px-tx)*(a*tx*tx+b*tx);
        cout<<setiosflags(ios::fixed)<<setprecision(3)<<ans<<endl;
    }
    return 0;
}


[ACM] sdut 2877 angry_birds_again_and_again (简单数学积分)

标签:acm   数学积分   

原文地址:http://blog.csdn.net/sr_19930829/article/details/41553037

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!