码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1698 Just a Hook(线段树,成段更新,懒惰标记)

时间:2014-11-27 23:44:20      阅读:289      评论:0      收藏:0      [点我收藏+]

标签:hdu 1698   just a hook   线段树   lazy思想   成段更新   

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18384    Accepted Submission(s): 9217


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

bubuko.com,布布扣


Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
1 10 2 1 5 2 5 9 3
 

Sample Output
Case 1: The total value of the hook is 24.
 

Source
 

Recommend
wangye   |   We have carefully selected several similar problems for you:  1542 1255 1828 1540 2871 
 

题意:
给你一个区间1~n,刚开始全为1,之后进行Q个操作,每个操作给出x,y,z,表示将区间[x,y]所有的数改为z。Q操作后求区间所有数的和。

题解:简单线段树,更新Q次,查询一次,懒惰标记。

CODE:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>

#define N 100010
#define Mod 10000007
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
typedef long long ll;

const int INF = 1000010;

using namespace std;

int add[N << 2], sum[N << 2];

void pushdown ( int idx, int m )
{
    if ( add[idx] )
    {
        add[idx << 1] = add[idx];
        add[idx << 1 | 1] = add[idx];
        sum[idx << 1] = ( m - ( m >> 1 ) ) * add[idx];
        sum[idx << 1 | 1] = ( m >> 1 ) * add[idx];
        add[idx] = 0;
    }
}

void build ( int l, int r, int idx )
{
    add[idx] = 0;
    if ( l == r )
    {
        sum[idx] = 1;///初始化为1
        return;
    }
    int mid = ( l + r ) >> 1;
    build ( lson );
    build ( rson );
    sum[idx] = sum[idx << 1] + sum[idx << 1 | 1];
}

void update ( int l, int r, int idx, int x, int y, int k )
{
    if ( x <= l && r <= y )
    {
        sum[idx] = ( r - l + 1 ) * k;
        add[idx] = k;
        return;
    }
    pushdown ( idx, r - l + 1 );
    int mid = ( l + r ) >> 1;
    if ( x <= mid )
        update ( lson, x, y, k );
    if ( y > mid )
        update ( rson, x, y, k );
    sum[idx] = sum[idx << 1] + sum[idx << 1 | 1];
}

int main()
{
    int t, n, m;
    while ( ~scanf ( "%d", &t ) )
    {
        for ( int i = 1; i <= t; i++ )
        {
            scanf ( "%d%d", &n, &m );
            build ( 1, n, 1 );
            int x, y, z;
            while ( m-- )
            {
                scanf ( "%d%d%d", &x, &y, &z );
                update ( 1, n, 1, x, y, z );
            }
            printf ( "Case %d: The total value of the hook is %d.\n", i, sum[1] );
        }
    }
    return 0;
}


hdu 1698 Just a Hook(线段树,成段更新,懒惰标记)

标签:hdu 1698   just a hook   线段树   lazy思想   成段更新   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/41554519

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!