码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4006 The kth great number(优先队列)

时间:2014-11-27 23:45:30      阅读:870      评论:0      收藏:0      [点我收藏+]

标签:hdu 4006   the kth great number   第k大数   优先队列   

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 6982    Accepted Submission(s): 2837


Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
 

Output
The output consists of one integer representing the largest number of islands that all lie on one line. 
 

Sample Input
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 

Sample Output
1 2 3
Hint
Xiao Ming won‘t ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  4003 4007 4004 4008 4005 
 


题意:n个操作,‘I’表示插入值,Q则问你第k大数是多少。

题解:
优先队列 priority_queue<int, vector<int>, greater<int> >的使用,每插入一个数都保存前k大的数,队首就为第k大的数。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>

#define N 100010
#define Mod 10000007
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
#define lc idx<<1
#define rc idx<<1|1
typedef long long ll;

const int INF = 1000010;

using namespace std;

int main()
{
    int n, k;
    while ( cin >> n >> k )
    {
        char c;
        int s;
        priority_queue<int, vector<int>, greater<int> >que;///从大到小排序,队首尾最小值
        while ( n-- )
        {
            scanf ( "%c%*c", &c );
            if ( c == 'Q' )
                printf ( "%d\n", que.top() );
            else
            {
                scanf ( "%d", &s );
                que.push ( s );
                if ( que.size() > k )
                    que.pop();
                getchar();
            }
        }
    }
    return 0;
}


hdu 4006 The kth great number(优先队列)

标签:hdu 4006   the kth great number   第k大数   优先队列   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/41554293

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!