码迷,mamicode.com
首页 > 其他好文 > 详细

Digital Roots,函数

时间:2014-05-22 13:01:21      阅读:223      评论:0      收藏:0      [点我收藏+]

标签:digital roots   函数   

 Digital Roots
时间限制: 1 Sec  内存限制: 128 MB
提交: 91  解决: 29
[提交][状态][论坛]
题目描述
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit. For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
输入
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
输出
For each integer in the input, output its digital root on a separate line of the output.
样例输入
24
39
0
样例输出
6
3
提示

数字可能很大,如99999999999999999999999999999999999999


#include<iostream>
#include<string.h>
using namespace std;
int t;
int su(int sum)
{
t=0;
    while(sum)
    {
      t+=sum%10;
      sum/=10;
    }
if(t>=10)
 return su(t);
    else 
return t;
}
int main()
{
    int n,sum;
    char x[1000];
    while(cin>>x&&x[0]!=‘0‘)
    {
        sum=0;
        for(int i=0;i<strlen(x);i++)
        {
            sum+=x[i]-‘0‘;
        }
        cout<<su(sum)<<endl;
    }
}

定义为数组,每位相加,最后为1位数,即为结果

Digital Roots,函数,布布扣,bubuko.com

Digital Roots,函数

标签:digital roots   函数   

原文地址:http://blog.csdn.net/u013240812/article/details/26164471

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!