码迷,mamicode.com
首页 > 其他好文 > 详细

HDU5112 A Curious Matt

时间:2014-11-29 20:18:02      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:hdu5112

A Curious Matt

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 25    Accepted Submission(s): 25


Problem Description
There is a curious man called Matt.

One day, Matt‘s best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.
 

Input
The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers ti and xi (0 ≤ ti, xi ≤ 106), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all ti would be distinct.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.
 

Sample Input
2 3 2 2 1 1 3 4 3 0 3 1 5 2 0
 

Sample Output
Case #1: 2.00 Case #2: 5.00
Hint
In the ?rst sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal. In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.
 

Source
水题。

#include <stdio.h>
#include <algorithm>
#include <stdlib.h>
#include <string.h>
using namespace std;

#define maxn 10010

struct Node {
        int t, x;
} E[maxn];

bool cmp(Node a, Node b) {
        return a.t < b.t;
}

int main() {
        int T, N, i, j;
        double ans;
        scanf("%d", &T);
        for(int cas = 1; cas <= T; ++cas) {
                scanf("%d", &N);
                for(i = 0; i < N; ++i)
                        scanf("%d%d", &E[i].t, &E[i].x);
                sort(E, E + N, cmp);
                for(ans = 0.0, i = 1; i < N; ++i) {
                        ans = max(ans, abs(E[i].x - E[i-1].x) * 1.0 / (E[i].t - E[i-1].t));
                }
                printf("Case #%d: %.2lf\n", cas, ans);
        }
        return 0;
}


HDU5112 A Curious Matt

标签:hdu5112

原文地址:http://blog.csdn.net/chang_mu/article/details/41598261

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!