码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2965 The Pilots Brothers' refrigerator

时间:2014-11-29 22:58:41      阅读:223      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

http://poj.org/problem?id=2965

  poj 1753扩展,dfs+枚举,不过加了一个路径。

                                                                              The Pilots Brothers‘ refrigerator
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 19278   Accepted: 7384   Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int ans[6][6];
int step;
int r[20],c[20];
bool flag=false;
bool judge()
{
    int i,j,sum=0;
    for(i=1;i<=4;i++)
      for(j=1;j<=4;j++)
           sum+=ans[i][j];
    if(sum==0)
        return true;
    else
         return false;
}
void flip(int x,int y)
{
    int i,j;
    for(j=1;j<=4;j++)
    {
        if(ans[x][j]==1)
            ans[x][j]=0;
        else
           ans[x][j]=1;
    }
    for(i=1;i<=4;i++)
    {
         if(i==x)
            continue;
       if(ans[i][y]==1)
            ans[i][y]=0;
        else
           ans[i][y]=1;
    }
}
void dfs(int x,int y,int d)
 {
      if(d==step)
     {
        flag=judge();
            return ;
      }

      if(flag||x>4)
        {
         return ;
        }
     flip(x,y);
     r[d]=x;//保存路径。
     c[d]=y;//保存路径。
      if(y<4)
       dfs(x,y+1,d+1);
      else
       dfs(x+1,1,d+1);
      flip(x,y);
      if(y<4)
       dfs(x,y+1,d);
      else
        dfs(x+1,1,d);

 }
int main()
{
    int i,j;
    char temp;
    for(i=1;i<=4;i++)
     {
     for(j=1;j<=4;j++)
      {
         scanf("%c",&temp);
         if(temp==+)
             ans[i][j]=1;
         else
           ans[i][j]=0;
      }
        getchar();
     }
     for(step=1;step<=16;step++)
       {
           dfs(1,1,0);
           if(flag)
               break;
       }
       printf("%d\n",step);
       for(i=0;i<step;i++)
          printf("%d %d\n",r[i],c[i]);
      return 0;
}

 

poj 2965 The Pilots Brothers' refrigerator

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://www.cnblogs.com/cancangood/p/4132078.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!