标签:des style blog class c code
题目链接:
点击打开链接
题目:
ACboy needs your help
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3741 Accepted Submission(s): 1935
Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
Sample Input
2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0
Sample Output
Source
Recommend
lcy | We have carefully selected several similar problems for you:
2159 1561 3033 2955 1171
这是一个背包九讲里面的分组背包问题:
具体代码如下:
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn=100+10;
int dp[maxn],a[maxn][maxn];
int main()
{
int i,j,N,M,v;
while(scanf("%d%d",&N,&M)!=EOF)
{
if(N==0&&M==0) return 0;
memset(dp,0,sizeof(dp));
for(i=1;i<=N;i++)
for(j=1;j<=M;j++)
scanf("%d",&a[i][j]);
for(i=1;i<=N;i++)
for(v=M;v>=0;v--)
for(j=1;j<=v;j++)
dp[v]=max(dp[v],dp[v-j]+a[i][j]);
printf("%d\n",dp[M]);
}
return 0;
}
hdu1712,布布扣,bubuko.com
hdu1712
标签:des style blog class c code
原文地址:http://blog.csdn.net/u014303647/article/details/26140673