码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1225 Football Score 【结构体排序】

时间:2014-05-22 12:45:13      阅读:291      评论:0      收藏:0      [点我收藏+]

标签:hdu1225

Football Score

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2579    Accepted Submission(s): 729


Problem Description
Football is one of the greatest games in the world. Lots of people like to play football. After one season of matches, the header has to calculate the last scores of every team. He is too lazy that he doesn‘t want to calculate, so he asks you to write a program for him to solve the problem.

Here are the rules:
1 Every team has to match with all the other teams.
2 Every two teams have to match for two times,one at home and one away.
3 In one match, the winner will get 3 points, the loser will get 0 point. If it is draw, both of them will get 1 point.
 


 

Input
The input consists of many test cases. In each case, there will be a number N in the first line which means the number of teams. Followed by N * (N – 1)lines. Each line stands for a match between two teams. The format is: "Team1 VS Team2 p:q", p stands for the balls that Team1 has kicked in and q stands for the balls that Team2 has kicked in. p and q are not greater than 9.

Process to the end of file.
 


 

Output
For each test case, output the teams and their scores in descending order. One line a team, the format is: "TeamX scores". If two teams get the same score, the one with high net goals will be ahead, which net goal means the difference between the total balls that the team kicked in and the total balls that the team lost. IE: if one team kicked in 30 balls and lost 40 balls, then the net goal is 30 – 40 = -10. If two teams have the same score and the same net goal, the one whose kicked in balls is bigger will be ahead. If two teams have the same score and the same net goal and the same kicked in balls, they will be outputed in alphabetic order.

Output a blank line after each test case.
 


 

Sample Input
3 Manchester VS Portsmouth 3:0 Liverpool VS Manchester 1:1 Liverpool VS Portsmouth 0:0 Portsmouth VS Manchester 1:1 Manchester VS Liverpool 2:1 Liverpool VS Portsmouth 1:2
 


 

Sample Output
Manchester 8 Portsmouth 5 Liverpool 2
Hint
Hint
Huge input, scanf is recommended.

 

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using std::sort;
struct Node{
	char name[100];
	int win, lost, points, net;
} arr[1000];

int find(char str[], int k){
	for(int i = 0; i < k; ++i)
		if(!strcmp(str, arr[i].name)) return i;
	return -1;
}

bool cmp(Node a, Node b){
	if(a.points > b.points) return true;
	if(a.points == b.points && a.net > b.net) return true;
	if(a.points == b.points && a.net == b.net && a.win > b.win)
		return true;
	if(a.points == b.points && a.net == b.net && 
		a.win == b.win && strcmp(a.name, b.name) < 0)
		return true;
	return false;
}

int main(){
	int n, win, lost, pos, id, sign;
	char name1[100], name2[100];
	while(scanf("%d", &n) == 1){
		id = 0;
		for(int i = 0; i < n * (n - 1); ++i){
			scanf("%s%*s%s %d:%d", name1, name2, &win, &lost);
			sign = win - lost;
			if((pos = find(name1, id)) != -1){
				arr[pos].win += win;
				arr[pos].lost += lost;
				if(sign > 0) arr[pos].points += 3;
				else if(sign == 0) arr[pos].points += 1;
			}else{
				strcpy(arr[id].name, name1);
				arr[id].win = win;
				arr[id].lost = lost;
				if(sign > 0) arr[id].points = 3;
				else if(sign == 0) arr[id].points = 1;
				else arr[id].points = 0;
				++id;
			}
			if((pos = find(name2, id)) != -1){
				arr[pos].win += lost;
				arr[pos].lost += win;
				if(sign < 0) arr[pos].points += 3;
				else if(sign == 0) arr[pos].points += 1;
			}else{
				strcpy(arr[id].name, name2);
				arr[id].win = lost;
				arr[id].lost = win;
				if(sign < 0) arr[id].points = 3;
				else if(sign == 0) arr[id].points = 1;
				else arr[id].points = 0;
				++id;
			}
		}
		for(int i = 0; i < n; ++i)
			arr[i].net = arr[i].win - arr[i].lost;
		sort(arr, arr + n, cmp);
		for(int i = 0; i < n; ++i)
			printf("%s %d\n", arr[i].name, arr[i].points);
		printf("\n");
	}
	return 0;
}


 

HDU1225 Football Score 【结构体排序】,布布扣,bubuko.com

HDU1225 Football Score 【结构体排序】

标签:hdu1225

原文地址:http://blog.csdn.net/chang_mu/article/details/26139493

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!