码迷,mamicode.com
首页 > 其他好文 > 详细

sicily 1388. Quicksum

时间:2014-11-30 13:41:03      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   ar   color   os   sp   for   

Description

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

A Quicksum is the sum of the products of each character‘s position in the packet times the character‘s value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":

        ACM: 1*1  + 2*3 + 3*13 = 46
MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650
 
Input
The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters. 
Output
For each packet, output its Quicksum on a separate line in the output. 
Sample Input
bubuko.com,布布扣 Copy sample input to clipboard 
ACM
MID CENTRAL
REGIONAL PROGRAMMING CONTEST
ACN
A C M
ABC
BBC
#
Sample Output
46
650
4690
49
75
14
15
分析:前面用 255 wa了,改成256 ac了,肯能题目描述得有点不太清楚。。
#include <iostream>
#include <string>
#include <map>

using namespace std;

char letters[27] = {
     , A, B, C, D, E, F,
    G, H, I, J, K, L, M,
    N, O, P, Q, R, S, T,
    U, V, W, X, Y, Z
};

int main(int argc, char const *argv[])
{
    char str[256];
    map<char , int> mapLetter;
    for (int i = 0; i != 27; ++i) {
        mapLetter[letters[i]] = i;
    }

    while (cin.getline(str, 256, \n) && str[0] != #) {
        int sum = 0;
        
        for (int i = 0; i != 256; ++i) {
            if (str[i] == \0)
                break;
            sum += mapLetter[str[i]] * (i + 1);
        }
        cout << sum << endl;
    }
    return 0;
}

 

sicily 1388. Quicksum

标签:des   style   blog   io   ar   color   os   sp   for   

原文地址:http://www.cnblogs.com/xiezhw3/p/4132838.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!