码迷,mamicode.com
首页 > 其他好文 > 详细

HangOver(杭电1056)

时间:2014-11-30 23:15:21      阅读:207      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   ar   color   os   sp   

HangOver

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9821    Accepted Submission(s): 4137


Problem Description
How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We‘re assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

bubuko.com,布布扣 

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
 

Sample Input
1.00 3.71 0.04 5.19 0.00
 

Sample Output
3 card(s) 61 card(s) 1 card(s) 273 card(s)
 

Source
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
	double n,sum,j;
	int i,k;
	while(scanf("%lf",&n)&&n)
	{
		sum=0.50;
		k=1;
		if(n<=0.50)
		printf("1 card(s)\n");
		else
		{
			for(i=3;sum<n;i++)
			{
				j=i*1.0;
				sum=sum+1/j;
				k++;
			}
			printf("%d card(s)\n",k);
		}
	}
	return 0;
}

HangOver(杭电1056)

标签:des   style   blog   http   io   ar   color   os   sp   

原文地址:http://blog.csdn.net/hdd871532887/article/details/41630573

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!