码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 1711 Sum It Up(DFS啊 )

时间:2014-11-30 23:21:11      阅读:219      评论:0      收藏:0      [点我收藏+]

标签:zju   dfs   zoj   

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=711


Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.


Input

The input file will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , . . . , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , . . . , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.


Output

For each test case, first output a line containing `Sums of‘, the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE‘. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.


Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0


Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25


Source: Mid-Central USA 1997


题意:

给出一个数字num, 后面在给出 n 和 n 个数字;

求他们的和等于num;

要去重!

PS:

去重借鉴别人的!

代码如下:

#include <cstdio>
#include <cstring>
int num;
int n;
int a[1017], c[1017];
int sum, k;
int tt, flag;
void DFS(int x)
{
    if(sum > num)
        return ;
    if(x > n)
        return ;
    if(sum == num)
    {
        flag = 1;
        for(int i = 0; i < k; i++)
        {
            if(i != 0)
            {
                printf("+");
            }
            printf("%d",c[i]);
        }
        printf("\n");
        return ;
    }
    if(a[x] != tt)
    {
        sum+=a[x];
        c[k] = a[x];
        k++;
        DFS(x+1);
        k--;
        sum-=a[x];
    }
    tt = a[x];
    DFS(x+1);
}
int main()
{
    while(~scanf("%d",&num))
    {
        flag = 0;
        sum = k = 0;
        tt = -1;
        scanf("%d",&n);
        if(num == 0 && n == 0)
            break;
        for(int i = 0; i < n; i++)
        {
            scanf("%d",&a[i]);
        }
        printf("Sums of %d:\n",num);
        DFS(0);
        if(!flag)
        {
            printf("NONE\n");
        }
    }
    return 0;
}
/*
5 7 1 1 1 1 1 2 2
6 8 2 2 1 1 1 1 1 1
*/


ZOJ 1711 Sum It Up(DFS啊 )

标签:zju   dfs   zoj   

原文地址:http://blog.csdn.net/u012860063/article/details/41629397

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!